exporting montage changes track lengths

have had a frustrating few hours and ended up having to save audio files one at a time as i’m struggling to understand what’s going on in this situation:

i’ve got a LOT of 1 minute audio files that are created and cropped to smoothly loop on playback. this is for a mobile app and the files have to be perfectly looping.

however, when all of these files (WAV) are put into a Montage, named, metadata’d, etc… and i export/render them all out in various formats tiny little gaps of audio and clicks get inserted at the beginning of each file.

i have the splice markers and gaps between tracks set at zero and when i render them out about 30ms of silence gets added to the front of the file.

i have just noticed also that simply opening a single WAV and saving as MP4 has also introduced this gap… completely bypassing the use of the Montage.

any idea what’s going on? thanks…

(see screenshot for gap)

encoded format are not suitable for loops, as these formats quantize the audio length.
The Mp3 encoder has an option to compensate for this, though.

thanks… yes, the more i researched this the more i found out that it may be a drawback of MP3 (and AAC i suppose?)

the problem is, my montage render/exports are also glitching the lengths even if i export WAV files… which, for this project isn’t a concern as the client needs AAC, but definitely doesn’t seem right.

Do you use plugins? Did you try while bypassing plugins? Maybe some plugins have latency compensation problems.

i first started noticing this because FabFilter Q3 introduces similar problems (no matter what phase setting you have). removing the plug in and trying others eliminated the “render in place” glitches/timing additions.

but exporting/rendering tracks from a montage introduces these problems even with no plug ins.

but exporting/rendering tracks from a montage introduces these problems even with no plug ins

Rendering without plugins and to WAV… I really doubt you can observe any gap.

No gap here.

@taylor12K: What settings are you using for rendering? Is the Resampler involved? I master a fair amount of projects that have overlapping tracks, or connected tracks so I am always checking for issues like this, especially when I try a new plugin because there is a 50% chance it will have a rendering issue in WaveLab.

Anyway, in my workflow I can render WAV files with no added gap and when you place them back to back in a new montage, they are 100% seamless with no ticks, pops, gaps, or other glitches. The only plugin running when I render my final master files is Goodhertz Good Dither.

I wonder if it’s something in your render settings that is producing this if it’s happening on WAV files that are otherwise seamless on playback before rendering.