Expression Map Key switches without a MIDI controller?

As the title implies, I’m trying to switch articulations with expression maps without the use of a midi controller. I’m entirely new to expression maps, but I’ve gathered how they should work with the MIDI controller. I plan on purchasing a MIDI controller in the future, but in the meantime I have a commission to finish and can’t afford one. It seems like when I input an articulation (when I can even get them to show up), they don’t change the sound output whatsoever. I also tried changing the note attack/sustain/delay in the mod window of the instrument itself within Kontakt (click wrench–> mod) and that doesn’t seem to change the sound either.

Any ideas?

Thanks in advance!

The expression map tool is just an easy way of isolating and labeling your keyswitches for ease of access, you shouldn’t need a MIDI controller to use them. But you do need to define your keyswitches with reference to where they would be on a midi keyboard. That is, when you go to set them up, the ‘remote’ column in the ‘sound slots’ section needs to contain the notes that your keyswitches correspond to, and the ‘Output Mapping’ for each keyswitch entry needs to contain the corresponding note.

This doesn’t really solve my issue. I believe I have things set up correctly in the Expressions Map Setup dialog (I downloaded a pack that someone else made for my VST instrument):

My issue is when I place an articulation into the score like this:

…it never has an impact. Only the Kontakt instrument menu changes the actual sound of the instrument itself when I select spiccato feather, Loure Long, sus molto vibrato, etc.

I don’t think it’s set up correctly tbh. For one thing In my expression maps, the notes under the ‘remote’ column in the ‘sound slots’ section are the same as the notes under the ‘data 1’ column of the ‘output mapping’ section. And the root note in the bottom left corner is C2. For another, the problem you’re encountering has everything to do with the expression map’s settings. That’s pretty much the only variable that would cause the keyswitches not to trigger. You can test this by removing the expression map and triggering the keyswitches the old fasioned way, if they work, it’s the expression map settings.

I don’t know what you mean by “the old fashioned” way.

I mean without the expression map. Just place the notes onto the keys that the keyswitches are assigned to.

Xanderpitz, your map is indeed set up correctly from what can be seen in the pic.

I think what you might be missing are one of these bits:

  • the way to place an articulation in the key editor is simply by adding it to the articulations lane, no midi note is needed (or can even be used) for that.

  • and/or that the remote keys are meant for real-time playback, which is why for this low string instrument they are in the upper octaves of the keyboard while the actual key switches are down beyond the lower octave of an 88 key piano- A-1 or midi note 21.

With this in mind, if the key switches aren’t working, check if the octave the keyswitch is in is wrong, and double check that they are actually correct by looking at the VST instrument’s interface, or by removing the expression map and manually striking the key switch note. e.g., midi note C0 also known as midi note 0 (zero). (you’d have to transpose the keyboard downward to do that of course.)

I had already checked the key switches by manually hitting the 7th octave notes on the piano roll and it was activating each articulation in the expression map box to the left. I’ve also tried having the key switch playing at the same time as the instrument like this:

The top note on the track is shown in the piano roll below as one of the articulations, and it’s being played at the same time as a C-2. I’ve even tried hitting the key switch then scrolling down below to insert or hit a note. Still no results on anything…

I don’t know what you’re doing since I’m not sitting next to you. But I’m not sure I have explained this in a way that works for you, So I suggest you read the documentation.

A midi controller is not needed for the use of the expression maps.

I’m not sure why they aren’t working? As Steve pointed out, the Expression Map seems OK. I don’t know your instrument, but it should work. You have the attributes set to direction and the line is there in the Editor. Try switching the articulations and observing the key switch changes. If the articulations are switching, but the sound is not changing accordingly, I’d re-check the Instrument settings, midi settings. BTW, the on-screen keyboard is available and may be useful to for some things. Good luck working it out.

So, I finally got SOMETHING to change! Unfortunately, it’s still not entirely what I need. I did a simple test of pizzicato vs. arco bowing on the cello and tried adjusting the length to 30% as shown here:

Lo and behold, it did shorten the note, so that confirms there was nothing wrong with the expression map setup or drawing in the articulations on the controller lane. However, the 30% length was simply the same bowed note…just 30% the length, no pizzicato.

Someone mentioned it could be the instrument I’m using. I’m using the Century Ensemble Strings pack from 8Dio running this simple test setup: The only options for the control switch are the given notes in the 1st octave or the CC09 program, which (while I believe it is activated in the drop-down menu on the controller lane) I have no idea how to use.

Thanks to everyone who’s helped so far btw, definitely on the right path now.

Expression Maps are complex. I don’t fully understand all the functions myself. A complex instrument like the one you’re using may have 1) it’s own quirks and limitations, 2) odd bits of behavior in how it works (or fails to work) within Cubase.

The users of the instrument will know a lot more about this. Id’ check Gearslutz and other Synth User websites for more. Perhaps someone here will post a few suggestions about Maps for this synth. Youtube has some good tutorials. Expression Maps haven’t changed much in versions going back to at least Cubase 7 I believe, perhaps even earlier.