Expression Map question

Hi
I use an expression map together with a VSL instrument. I have 7 key switches and the lovest - Celesta - is F0. Every time I stop Cubase (7.5 on Mac), this keyswitch (F0) gets selected an the instrument will play the Celesta sound. But I want the instrument to play the sound from the LAST keyswitch in the part - here it’s Xylophone.
Skærmbillede 2014-11-15 12.50.14.png
Why does Cubase return to the first keyswitch in the map when it is stopped?
Any help would be very much appreciated!

Try adding an empty dummy entry as the top (i.e. default) sound slot. Whenever it gets triggered nothing will happen.

I’m not sure what I have in “Preferences” at the moment, but I believe the keyswitch that is active will be the one under the cursor, or if nothing is under the cursor it defaults to the first slot. In other words, if you stop your playback and your cursor is over “Xylophone”, then the xylophone will be active.

Mahlon

This is not the case! Every time I stop Cubase the Expression map will return to the first slot. But I wonder if it has something to do with the midi setup in VST instrument?
The same time the mod wheel don’t get through to the instrument.

That’s why you want to have an entry in the first slot that does nothing. Then it won’t reset your articulation when it gets activated. You can just add an empty slot at the bottom of your list and then drag it to the top.

Mahlon’s description is how it should work if you have your Preferences/MIDI set to chase events. However a bug got introduced in 7.something where it sends out slot 1 instead of what is under the cursor. Steinberg acknowledges the problem and presumably it will be fixed in the next update. In the meantime the workaround is to have a blank first slot.

http://www.steinberg.net/forums/viewtopic.php?f=195&t=64603
http://www.steinberg.net/forums/viewtopic.php?f=196&t=64048