Expression map symbols not attaching to correct note

Sometimes (actually quite often) when I try to attach a note symbol (expression map or note symbol) to a note, it ends up on the wrong note. See attached video:
Note symbols
The notes do not overlap: here are the same notes in the key editor:

Does anyone have any idea what is going on please?

First of all, please explain why the notes counts in the measures of your bass clef are wrong.
It will probably answer your question.

1 Like

An excellent question, which unfortunately requires a rather long answer. In fact how rests get treated is something of mystery to me. As far as I know you cannot add or delete them (except for purely graphical ones - I have definitely not used any of these), and cubase automatically puts a rest where there is no note.

This bar (and I have many with the same problem) had previously shown too many rests, so I turned all rests off as being the least worst option. Both staves are on a single track. Voices 1&2 (midi channels 1&2) are on the upper stave, voices 5&6 (midi channels 3&4) are on the lower stave. If I turn rests back on that bar now looks like this;
Now there are too many beats, rather than too few! I have tried all combinations of rests on/off I can think of, including setting “reduce rests” to either “all” or “whole notes only”. However, whatever combination I choose, I can only have no rests, or too many rests as shown in the two pics above. All the notes in question are in voice 5 = midi channel 3. (Voice 6 = midi channel 4 is only used in a very small number of bars, and this isn’t one of them).

The problem with the rests does not seem to occur in the upper staff (voices 1 and 2), but as shown in the earlier video clip, there are nevertheless notes on that staff that will not accept an expression map symbol

I’m afraid I’m out of ideas at this point.

In case it is relevant, my current score settings (too many rests are visible) are as follows:

Update: If I recreate those two bars note-by-note from scratch elsewhere in the score on the same track, then neither the problem with the rests or the problem with the expression map occur. It must be something to do with editing I have previously done to that particular bar that has screwed up the rests somehow.

If I copy (rather than re-create) the problem bars to a new location (same track), the problems (too many rests and the note symbol problem) persist in the copy, whether I copy in the score editor or in the key editor. There is clearly something funny about those bars that I cannot see and have no idea what it is, presumably caused by my previous editing, that has forced too many rests into the bar somehow and now I can’t undo it.

If there is an obvious solution then great, but if not then unfortunately it seems I will have to delete all affected bars (there are quite a lot) and re-enter them.

There are probably events in those bars that are not visible and may be the cause of what you’re observing.
Two ways to find out what is hidden there:

  1. Check all the filters at the top of the score page in the Score Editor window.
  2. Look in the List Editor

Remove or modify those invisible events in the score as needed.

1 Like

Nice, you could be onto something. The score editor shows there is hidden stuff:
But I think they are just the rests in the unused voices. The list editor looks like this:

If I delete everything in b11 and b12 that is not a note in the list editor (which included some cut flags) the result is:

Sadly, there are still too many rests.

What do you mean by “there are too many rests”?
The rests are correct now.
What is your goal?

Hi Maestro, the goal is this:
The above was created from scratch note by note in the same track. Cubase has calculated the rests correctly this time, but I have not done any corrections or editing, it is freshly done. I think you are right that it is the rests that are the problem with the original, and the expression symbol error is just a symptom, because with the rests calculated correctly, I can put the expression symbols where I want them. In the above image both the rests and the expression symbols are correct.

Compared to my previous post, which is reproduced and annotated below, the rest circled in red should only be a quaver rest, not a crotchet rest, while the rest circled in blue should not be there at all:
In the lower stave if you add all the notes and rests together there are 5 beats in this 4 beat bar, which should not be possible. All the notes are in voice 5 (midi ch3). The rests are calculated by cubase.

In my problem bar, I conclude that cubase is not calculating the rests correctly. More than likely this is due to editing I have previously performed on that bar, but even so, I would not expect to encounter a problem like this just because I changed notes around and used the cut notes tool etc. Further, there is now nothing showing as hidden in the score view:

Or in the list view:
So there must be something else about that bar that is causing cubase to calculate the rests incorrectly. As I say, this is not the only bar where I have a similar problem, so while it would be feasible to delete all those bars and re-do them from scratch, I don’t feel that would be getting to the root of the problem of why cubase is currently not calculating the rests correctly. Hope this explanation helps clarify the issue a bit.

I suspect there is a voice “mess” here.

You have the rests set to be centered, so you can’t see which voice they belong to. This makes troubleshooting too difficult.

1 Like

What does this refer to?

I think some notes are set to voice 5 or 6 in the lower staff, and then the user has possibly hidden unwanted rests.

Maybe something like this


Here is the same with rest centering turned off:

I find it difficult to believe there are any hidden rests. At any rate if there are any, they do not show up in the score view with ‘hidden notes’ and ‘hide’ both turned on, or in the list editor either (see images in previous post).

In any case, if there were hidden rests, that would reduce the time available for non-hidden rests, so I might see less rests than expected, but I am seeing the opposite - the rests take up too much time compared to the notes.

Concerning a potential voice mix-up, if you look at the list editor in my previous post, you will see that there are 5 notes in midi channel 3, which is equal to voice 5, and 14 notes (which is all the others) are in midi channel 1 which is equal to voice 1:
This note count is consistent with what stave the notes are on in score view, and also with what voice cubase reports for the notes when I click on them:
Note that when I click on a rest, cubase reports a voice (voice 5 for the lower stave and voice 1 for the upper), but channel indicator disappears.

I hope this enough to show that the underlying cause is probably not a voice problem, at least not for items that are visible. If it is down to items that are hidden, I suppose this is possible, but they must be hidden so well that neither the list editor nor the score editor can find any trace of them.

Maybe you could attach your Cubase project file containing only those two bars here so that @steve or I (or other users) could have a look.

Also, for troubleshooting this, set voice 1 to Auto.

There’s no advantage to manually setting it as up, as stated in the manual.

1 Like

Happy to post the file, will cut it down and do it later. Regarding setting voice 1 to auto as above, please clarify which setting you mean? Thanks.


Attached is a file containing the problem bar and the bar after. I have changed stems to auto, and rest centering to ‘off’.

Note that this is extracted from a version before I started trying to find and remove hidden items by going into the list editor and deleting them. Therefore, there are two hidden rests on the upper stave, voice 1. However, when these are un-hidden, it makes no difference.

Rests and Expression marks.cpr (465.1 KB)