Expression maps affecting acoustic feedback in piano roll


I’m currently setting up a template in Cubase 8.5 with several instances of EWQL Play opened. Everything is running fine except for one thing. Tracks that have expression maps don’t behave correctly in the piano roll. When I place a note, I hear a small sound (the actual patch but played for a fraction of a second). Same when I change the velocity. If I remove the expression map, it starts behaving correctly. If I write a part with several articulation, the playback is perfect. The issue seems to be related to the acoustic feedback. When I use the score editor and activate the acoustic feedback I can hear the sound just fine.

I have tried using remote program change instead of remote keys but it doesn’t change anything. My CPU is not overloaded at all, maybe at 10%, and I still have 20gig of ram left. I’m new with expression map so I’m wondering if my problem is there or if it’s related to my hardware. I think that the problem could be that I’m loading the sample from a 7200 rpm hard disk drive (for now). Anyone have a similar issue or know what the fix could be?

Edit: This also happens on or VSTIs, like Zebra2.


What data do you use (send) in the Expression map?

I’ve tried using keyswitches (latch mode on and off) and program changes in the program settings. In the output mapping I’ve tried using note-on and using only midi channel change.

So you are sending just change of the MIDI Channel?

I’m just thinking, what is the init status, before you send any message.

I have the same issue. It doesn’t matter if the map is a direction or an attribute. Once a note placed, clicking again causes it to sound correctly. I just ignore it.

Not sure what is meant by init status, but I’ve tried using attribute and direction. I’ve read threads on other forums with people having the same issues but never found a solution. Note that I’m using a steinberg audio interface (ur-242) with the steinberg driver. When I put the buffer to 2054 it seems to be a little better but it’s still buggy. But I don’t think it’s a latency or CPU issue, as everything else is working perfectly…