External effect delay question

Hi,

I never used my outboard gear with the external effect window.
I gave it a try but I don’t understand the delay compensation that pops up when creating a new FX track.
That video says to clic “measure delay” to ping and automatically get the amount of delay.
i clic but get nothing.
So i tried to add this effect as insert on a track, if I render in place the region the waveform coming back is before the beat 2.3ms
… I don’t understand why this is before the beat. Maybe there’s a compensation somewhere that is not properly set (the midi track I use is set to 0 delay though… so I don’t know where it comes from)
My RME802 is 1024 buffer no compensation option there. ( Constrain Delay Compensation is off)
any idea how to get this right ?
thx

You have to measure the delay while in playback.
(When no other audio is playing, so playback “nothing”)
:slight_smile:

Fredo

1 Like

Thx.
Ok I I was pressing button while stop.
but still getting no value for delay :face_with_raised_eyebrow:
Sound is going though because I can hear the effect on tracks I use as insert or FX track.

Then it probably means there is no delay.
The Delay from the soundcard is already takin" care of.
So if you “measure” an analog compressor, it might be that you don’t measure any delay.
Try a digital reverb unit or so, were you can dial in pre-delay.

Carefull, delay sometimes varies according the used preset and some units have a variable delay (digital compressors for example)

Fredo

ok I’ll try digital delay.
What I don’t understand is I can hear a of phase between dry sound and the sound returning from the outboard (1073eq and culture vulture)
and When I bounce it the audio return is 2.3ms in advance…
Myabe something to be fixed on RME soundcard ?
I’ll check on their forums.

Just to clarify the procedure:
-Set up your connections
-Playback “nothing” from Nuendo.
-Ping the delay.
-Stop playback

====>>> Your delay should be set.

Also know that delay can vary depending on the (digital) presets and/or (analog) settings used,
Especially digital compressors often have a variable delay; so you can’t measure those correctly.

Fredo

Hi Fredo.

Sorry i’m back on this subject. I still have a problem and I don’t understand how to fix it.
I have a simple session with one track I want to master.
I use bus + and culture vulture as external gear.
I want to have the culture vulture in parallel. But it always gives me a phasing. Because of delay I guess.
I do the exact procedure as you describe but can’t get it to work (if possible)
1 audio track > send out to FX track
1 FX track with culture vulture.
in external gear the vulture is on my main soundcard RME802.
I go in an empty space / press play / hit measure
it comes back “0” as you said if it’s analog gear and soundcard delay is already taken care of then should be 0.

But the sound is always phasing like it’s not align.
I tried to manualy adjust the delay but it only gets worse.

So what I did is on the FX track (parallel return from the vulture) I added a Mixer Delay at 10ms. And try to adjust the delay until sound is ok. I have to delay the FX track by 1.15ms to be aligned…
So if I could enter a negative value of -1.15ms in the external insert window I guess it would be aligned without using the mixerdelay.
also I do this by ear… so 1.10 to 1.20 is good that’s why I took 1.15 but I would prefer another way to measure.

I don’t understand what I’m doing wrong that I need a negative value in the delay. I might have some wrong settings somewhere (?)
Also I tried to change the soundcard latency to 1024 and the 1.15ms setting still is ok.
any idea ?

Not sure what you are trying to do.
I am confused about FX tracks and such.
Culture Vulture is a compressor, no?
So how can you have it on an FX track?

The latency is pinged in the “External FX” section in Control Room.
Once that is done, you can use your external gear as a plugin.
Sure, you can insert that plugin into an FX track, and yes, it should be latency compensated.

Mae sure that your hardware compressor is working: “on”.
Vintage compressors can surely have a different latency at different settings.
And most compressor will also vary in latency when working.

That is as far as my guesses go.

Fredo

Hello,
vulture is a valve stereo distortion for mastering.
I want to use it in parallel on an FX rather then wet on the master.
But you could do the same with a compressor on an FX track if you want parralel compression and don’t have wet/dry on your unit (plug or hard)

But any latency in a unit, you should have a positive latency to add in nuendo not negative :stuck_out_tongue: this is what I don’t get.
Thanks for your answer though I’ll keep looking.

Are you using RME Total Mix FX for routing? I use it with my Raydat and external effects in Nuendo, and I’ve found that it’s usually something with my physical patching or faders within Total Mix that is stopping the ping from reaching the gear, causing no delay adjustment. I’d be sure to check the hardware outputs in relation with the software outputs in Total Mix and go from there. Just a guess though

correct total mix is routing my units.
Basically the “software platback” line goes to the “hardware output”
I guess you need to do it like this no ? you can’t just ask nuendo to go directly to the physical output of the soundcard withot using total mix ?
interesting.
but anyway… that ping would have to be negative and I don’t see nuendo alowing that.
Or maybe there’s a buffer in totalmix that is not set correctly.
Thx I might ask on the RME forum.

Yes the basic way I do it is I click on the hardware output I’m using in Total Mix for the effect, and I make sure the related “software playback” faders for that hardware output is up, and then make sure those same “software playback” faders on your main monitors are down, as well as the corresponding inputs of the external plugin.

Thanks I looked into it and yes I can see when I click on measure delay that there’s a very loud level going out of my software playback send to the unit same on the hardware output channel corresponding to the send to my unit.
I see the unit reacting (compressor reduction engaged) and the audio going back in the soundcard hardware (from the return unit)
but delay is always 0.
I bypasse the unit and do measure again but it’s same.
If I want it in parallel on an FX track I need to add a negative delay.
I’ll ask on the RME forum what am I missing and maybe steinberg support.

So i created an audio track and sent the audio to my gear and recorded it back in this track.
The sound recorded is 0.001sec to early. (50 samples) whatever my SC buffer setting.

So it’s very small but consistent and maybe that’s why I hear a phase (although 0.001ms is crazy small) and that’s wy my “measure delay” always comes back with 0.
but why is it a negative value ?
is there a setting somewhere that can over compensate some latency ?
50sampl delay

So I guess I should enter -0.001 in the delay window from the external FX’s insert. but not only I can’t put negative values but 0.01 is the smallest amount we can enter (but it’s audible no doubt)

Doing a search, it appears people have had this problem as far back as 16 years ago :flushed:

Are you connecting your RME802 via firewire or USB? Did RME ever respond about the issue? I wonder if anyone has ever been successful with routing external effects with the 802?

Hi,
thx for the links.
I didn’t write to RME yet. Looks like the gearspace forum says it’(s fine with some RME sc not others.
I’m sure they asked RME about it. But conclusion from this forum is it is more steinberg that needs to do something. Other Software can ping and manage those negative values.
I’m using USB.

quote from RME forum
" This is a limitation of the ASIO protocol. It only allows one set of offsets (discrete for input and output) to be reported to the host.

This is indeed an issue that needs a solution at the ASIO protocol level, but we can’t blame RME in the slightest (I’d suggest yelling at Steinberg/Yamaha as Steinberg developed ASIO)…

The good thing is you can generally compensate in the DAW Software if the SLOWER converters are the standalone ones. This means the interface’s ASIO driver is reporting less latency, and the standalone converter will be behind it (latent).

DAW software can generally measure analog DA/A I/O loops and account for a positive delay. Accounting for a negative delay (when standalone converter is FASTER than what the ASIO driver reports) can cause issues in certain DAW’s (like Cubase/Nuendo).

Manual re-alignment is always an option, but even “Sample Level Nudging” can still reveal a non-perfect sum due to the fact that not all converter chips end up with a nice round offset (converter oversampling happens at many times the base sample rate, and will often yield offset requirements that are a fraction of a sample, and not able to be completely accounted for in a DAW)."