External Effects Cubase 12

Hi everyone.
I’m having trouble with getting my Lexicon MPX500 working as an external Effect.
I have Cubase 12.0.20, UR-RT4 interface, 2020 iMac 27" i7 processor, 32G memory.
I have set up the MPX500 in the Ext FX section of the Audio Connections panel, using send bus 2 and return bus 5&6.
The problem is that the unit does not appear in the track inspector under Inserts/External Effects, so I cannot use it as a VST plug in.
The weird thing is that the mix console shows signal going into the MPX and coming back from the unit. MPX is showing input on its meters.
But I hear no reverb effect.
Anyone have any clues as to what might be going on?
(I have read the manual thoroughly on this topic, and trolled various help You Tubes but without success)

So I take it you added the effect in the mixer and it doesn’t show in the track inspector in the project window? If I have that right, have you tried adding it from the track inspector instead of the mixer? Might be a small bug preventing from working when added from mixer? Worth a try anyway.

Hi SF, Thanks for your quick reply!
I think you understand my issue.
Here are a couple of screenshots to illustrate.

I hope that works.
There is nothing to click on in the track inspector,
so I cannot add it to the track.

I think your problem is an easy fix. The EFX is connected to your interface but you haven’t chosen the correct path to return it to your channel. Go to channel INSERT, select Steinberg from your EFX plugins, and then scroll down to ‘External Efx’. Click on this to add to your INSERT. You’re all set, check the latency and adjust your levels.

Thanks for your reply mr.roos.
Your diagnosis is probably good.
But I am not understanding your instruction: “/Channel insert, select Steinberg from…”
Do you mean the channel insert on the Inspector? - As in the above screenshot. (my tab is labelled, “Inserts”)
If so, I do not have an option “Steinberg” in the FX plugins.
Am I looking in the wrong place?

Are you using custom plugin lists? If so, you’d need to add this external fx ‘plugin’ to the list.

In the screen shot of the audio setup window, the mpx500 has the red (-) mark on it.
This means that the mpx500 became missing at one point and you had set inputs and outputs again.
However after the disconnection, you have to do an extra step,you need to right click on the name on the F4 window, then select “reconnect”. ← I can’t remember the exact wording but something like that in the contextual menu.
And it will be back online and be listed in the insert menu again.
This is a kind of meaningless step to do but it had always been implemented that way.