External FX negative delay compensation


Someone please help! I sometimes post some issues and do realize that importance is subjective. For my posts I mostly get no response at all giving me the feeling I don’t belong.

I posted earlier about External FX delay compensation not working for my BOSS GT-001 Guitar Effects Processor. Is it true that negative delay compensation values are not possible in Cubase? I found some posts from years back about the very same issue. Can anyone with this expertise confirm this or help? I already been spending some hours on how to fix this and in the end it appears to be a non exsisting feature.

That would leave my reamping with the GT-001 inaccurate. The amount of time shift is audible as well! To illustrate I did the whole thing in Studio One where delay gets detected correctly (-43 samples) and the render and source are exactly in sync:


In Cubase it reports 0.00 ms because it can’t go below that! Positve values only make the problems worse! The result is that the Render is audible out of sync:


Any help is highly appreciated.

This is strange. Negative delay compensation shouldn’t be possible. When you think about it how come that processed signal comes back before you even send it. But I’m afraid I have no solution for you.

Relativity? :face_with_hand_over_mouth::grin:

Hi Misohoza… Thanks for your reply. Yes… Indeed strange that the rendered signal is ahead of the original one. I read somewhere this has to do with the fact that I am using the External FX over USB. This GT-001 is a desktop USB device especially designed for this purpose. It appears the signal is ahead of the rest of the system somehowe. I also tried a blank project with only one wave file but it made no difference. We are talking milliseconds here.

Still it appears to be possible. Studio One has it implemented and it works just fine there.

Anyway thanks for your response :slight_smile:

Yes… Back To The Future :slight_smile: Anyway… see my other response :slight_smile:

I wish I could be of help, but I don’t use external effects. But sit tight, I believe others that do use them successfully will chime in with some help.

Thanks… I hope so too. I did some searching but found no solution.

EDIT: I found this video and it was helpfull. This seems the way to fix it.


Cannot say it is intuitive or something and the calculation did not give an accurate result. But after some experimenting it worked for me with a setting of -3000. So when I go reamping with my GT-001 I will set “Record Shift” to this negative value and the recording is in sync.

Record Shift

Thanks for the replies.!

1 Like