External FX Ping with RME Interfaces Still Not Fixed

External FX ping with RME interfaces (I have a Fireface 800) is still not working.

This has been a known issue which goes back several versions and still has not been resolved despite the following undertaking in Sound on Sound Dec 2011 issue of Cubase Notes - Using Outboard Gear:

" it is possible for an interface to report negative latency, and Cubase’s external FX can’t cope with this"…

While there are a couple of workarounds suggested in this article, the author goes on to say:

“unfortunately this does not work on my system (Cubase fires the signal out , but the compensation remains set to zero), and still can’t compensate for negative latency. I’ve mentioned this to Steinberg, who recognize that there’s a bug, and have said they’ll fix it in an update during the current product cycle”.

This has been the thorn in my side with Cubase, as I rely on external FX with my hybrid setup.

Very very disappointing Steinberg. Any response welcome!


I’m quite surprised that you’re having problems, that bug was fixed a long time ago, at least for me. What’s your setup?

I’ve been using different RME soundcards for the last 15 years and remember having the External FX ping problem around 2006. The ping returned zero latency but I could make it work by phase inverting the outputs in Total Mixer, it didn’t always work, but at least it did most of the time. Then as far as I remember RME released an update and the problem was gone, and has been since then. At the time I was using an RME HDSP PCI-card, then I changed to a Fireface 800, and didn’t have any problems at all. I use External FX all the time when I mix and master music, sending drums to parallel compression and lead vocals to parallel distortion - even a one sample offset would ruin my mixes and External FX has been rock solid.
When I needed more I/O I sold the FF800 and bought an RME HDSPe RayDAT and now I use it together with a RME HDSPe MADI soundcard, creating a massive ASIO driver with four ADAT I/O, MADI I/O, SPDIF, AES-EBU and a stereo analogue out from the MADI soundcard.
And I’m using at least five or six different External FXs, two TC Reverb 4000, stereo and mono analogue processing chains, parallel stereo drum compression/distortion and two custom tweaked Dolby CAT22 processors for parallel vocal distortion. And it works like a charm, even in Cubase 8 PRO.

I use the latest RME drivers available on their homepage. Usually have a round trip latency of 1.58ms or so at 44.1kHz depending on which converters I’m using - Antelope Orion32 or Mytek 8x192.

I hope you can tweak your system to make it work again. Try the phase-invert trick!

The best of luck

Hi Fred, thanks for the reply.

I am using an RME Fireface 800 with an RME ADI-4 DD connected to the Fireface’s ADAT I/O. The ADI-4 DD functions as an ADAT to AES/EBU or SPDIF converter. I have three effects units (Lexicon PCM91 and two TC Electronic M-ones) connected to the ADI-4 DD via SPDIF, so the signal paths are all digital. When I ping the external effects I can see the ping on the input metering of the effects instantaneously, but I get the return of the ping in Cubase FX return channels with a delay of about 1 second. Usually I get a compensation delay of 0ms registering, sometimes I get 100ms. I have tried inverting the phase in TotalMix as you suggested to no avail.


Okay, at least you’re using effect processors/reverbs so the ping time isn’t that important, I guess. But it should of course work properly.

Just as a test, I took away my External FXs and started over. No problems at all pinging two TC Reverb 4000 units hooked up on two analogue stereo lines (reverbs running at 96kHz internal sample rate).

I hope Steinberg and RME can sort it out for you.


It’s not working correctly here either. I am trying to do parallel compression on some drum tracks with an external compressor, and I am getting phasing. Cubase keeps reporting 0ms… I have heard this is RME’s fault… I have heard it is Steinberg’s fault. I don’t really care who’s fault it is… Steinberg, please talk to RME! Maybe if you work together, you guys can come up with a fix on it… very frustrating…

Ok… In the meantime this is what I did:

I used the “test generator” plugin to send a sine wave out, flip phase on the return from the outboard gear, and adjust the delay manually until I have silence… I’m feeling very annoyed that I have to do this… a very slow process that should be instant if hardware insert delay compensation was working correctly. PLEASE FIX THIS SOON.


No matter what latency or delay RME reports… it is irrelevant. Cubase sends out a ping signal - and Cubase ought to be able to calculate the adjustment based on when the ping signal returns. This is a problem with Cubase, not RME hardware.

I’m trying to set up external FX for the first time and getting major delay, testing with a drum loop everything sounds like double hits. Im moving the delay comp and doesnt seem to be getting any different. The measure effect loop button brings back 0 like stated above. Im using an RME 9632 with two extension boards. Any advise or other settings Im ignoring?

This has been broken for many years now. I hope they will make it a higher priority fix. Very frustrating.

Yes it is. Ive only had a small chance to mess with it as im busy mixing but i get delay style double time drums unless i drop the sample buffer to like 64 which is impracticle as i use a lot of vst instruments.

Still always reporting 0ms!

Is this EVER going to be fixed??? It has been broken for many versions now… I am working on a mix where I am in need of this feature. I went to try it - STILL BROKEN (8.5.20). Please Steinberg! Please fix this!!! How many more years is it going to take to fix this???

Sorry for being so angry, but it has been years and years… and to discover it’s still broken… It just makes me feel really frustrated, and it’s hard not to get angry that it has been ignored for so long.

Bounce… 5 years and counting I think (the Sound on Sound article came out in 2011?)…

It kind of works here, but only on some. I have 3 compressors hooked up and 1 reports 1.68ms the other two report zero. Filling in the 1.68ms manually for those two works. I am suspecting the levels have something to do with it, but have not spend to much time on it.

Yeah… Hopefully they will fix it completely some day. 5 years is a SERIOUSLY long time for a desireable feature to remain broken. Hopefully they fix it before I grow old and eventually retire from the music industry… :neutral_face:

I found this topic just as I was getting ready to try to get hardware inserts set up and didn’t realize there was a problem. Makes me not even want to fool with it as it seems likely to end in frustration with more half-assed feature implementation issues, gets old after a while.

Strange today when mixing I tried the ping again, and it worked on all the hardware inserts.

I’m having this same issue with a Yamaha spx2000 effects processor. I have several pieces of outboard gear, and the latency ping is working on all of them except for this box. Which is really bizarre considering the business relationship Yamaha has with Steinberg. I’ve had this issue in both the analog and digital ins/outs of the box. It only works on a few of the presets, specifically those that are modulation related. But anything that has a delay or reverb either calculates as ‘0’ or the maximum of ‘100’. I’ve tried adjusting the send and return levels and done about everything I can possibly think of. Very frustrating.

Have you tried setting the external delay/reverb to dry ?
Then ping, and after it got the latency calculated, back to wet.

I’m not able to ping it with the reverb off unless I switch to a different effect. What I did try to do was ‘0’ out all the settings and then ping it, which appears to have worked, even though the time calculated is far longer than it was for all my other outboard gear. The strange thing is all the other outboard gear calculates exactly the same (.98ms) while the spx2000 calculates 21.18ms. I I have yet to see if using any different reverbs, delays, modulations, or amp simulator effects from the box will yield different ping calculations, but that’s what I was able to come up with just in case anybody else has been having this same problem.

Maybe next time I’m in the studio I’ll experiment with testing at different latencies. Maybe that has some affect on whether ping works or not.

The last few times I have attempted to use the feature though, it would only report 0ms. Very frustrating…

That would make sense in a way and could be the root of this whole thing, since I often switch latency settings for different projects, I’d hate to have to re-ping every time. If this is the case, seems like Steinberg should have noticed this and made the info more available.