External Gear Bypass Issue / Lockup

I seem to be having an issue with Wavelab 7 on the Mac using external gear and the master section bypass button. I set up my plugin chain to add a few plugins then send the signal out to my analog chain and then back in to Wavelab. Everything seems to work fine until I hit the bypass button. Once I hit the bypass button all of the effects are bypassed like normal, however, if I switch to a different wav file and try to play it Wavelab locks up and I have to force it quit.

If I don’t use the external gear plugin I can bypass and switch between wav files with no issues so it’s definitely isolated to the external gear plugin.

This issue is a show stopper for me and I would assume many others. Being able to switch between wav files for comparison is critical.

I’m running an up to date version of Wavelab 7 as well as Mac OSX Snow Leopard. Also my interface is a Universal Audio Apollo Quad with updated drivers.

Any ideas? Thanks

I can’t reproduce a problem (short test).
Do you switch between waves with different sample rates?
How do you switch from wave to wave? How do you (re?) start playback?

Thanks for your reply

Yes I do, sometimes.

I just switch to the tab with the wav on it in the audio editor. I start playback by either hitting the spacebar or pressing play in the transport.

It seems the problem is a little worse than I initially thought. You don’t even need to switch wav files basically just hitting the bypass button and trying to resume playback on the save wav will cause a lockup.

I’ve tried to narrow it down a bit. It seems the issue happens after the External Gear plugin. So everything before and up through the External Gear works fine and can be bypassed and have playback resumed with no issues. However, if you add a plugin after the External Gear that’s where the issue happens. It appears that this issue presents itself if the next plugin after the External Gear plugin introduces latency.

Here’s a testing example with the following plugin chain.

UAD Brainworx bx_digital V2
External Gear
Fabfilter ProQ

If Fabfilter ProQ is in standard mode, the bypass works just fine and attempting playback will work just fine. However, if you put ProQ in to linear phase mode with maximum latency now attempting playback will lock up. I’ve reproduced it with other plugins as well such as the UAD Precision EQ and UAD Precision Limiter as well.

This is a huge problem. Anyone know who I need to contact at Steinberg to get this issue reported and hopefully fixed? I just switched to Wavelab so I am new to the process. I’ve used it for a whole 10 minutes since I just bought it and I can’t use it as intended right now. So I am dead in the water. Honestly I can’t believe nobody has found this bug yet. Thanks.

You already talked to the man. PG (Philippe Goutier) is the developer and initiator of Wavelab, and still always helpful in the forum. Hopefully he’ll acknowledge the problem and comes up with a solution…

BTW, have you installed the latest version? (7.2.1).

Yes, I am running 7.2.1 build 600.

I have found similar issues in other software packages where they basically had an issue with handling delay compensation after audio comes back from an external source. Obviously I don’t have knowledge of the internals of Wavelab, just throwing that out there.

If you need any further information please let me know. Thanks for the help.

Arjan, thanks for the reply. I’m new to the board and to Wavelab 7 on the Mac. I was a Wavelab user back in the 3.x days on Windows. When I went to the Mac I started using Peak. Now BIAS went out of business and I switched back to Wavelab for the Mac. Really hoping to make the best of it, it’s just this issue is a big deal for me.

As a matter of fact, maybe you are using some plugins with unusual latencies, that cause some not-tested configurations.
I don’t know if that can help, but try to increase the number of buffers, in the Option tab of the Audio Streaming dialog (Options menu). Default is 16, try 32.

BTW, what is the latency of your audio card? Don’t use anything under 512 if you want to be safe (for 44.1/48k files).

I don’t think so. I mean, I am using extremely common plugins. The precision items from Universal Audio as well as Fabfilter ProQ are pretty common in my book. ProQ is a nice EQ to test with this because you can change the configuration in to linear phase with latency added. So you can actually see the difference in Wavelab from one configuration to the next and then see it crash when hitting the bypass button.

I tried changing this before I posted my first message and it didn’t seem to make a difference.

Yeah, it’s set to 512. As I mentioned before I am using a Universal Audio Apollo Quad with the most up to date drivers. Please let me know if you need any further detail.

I can now reproduce the problem you describe. This is a fault in the External Gear bypass function.
You could use the plugin On/Off switch instead, though this is not as fast.

Thank you. Any idea on when this will be fixed? I’m assuming I have to bypass all of the plugins individually that I would have in a chain in order for this to work correct? That could certainly get tedious depending on how many plugins are being used.

I can’t verify this workaround because I am on the road away from the studio this week. I’ll certainly give it a try on Friday when I return. I’m anxious to start using the product for my regular activities.

No, only the External Gear bypass has a problem. Other plugins have not.

Sorry, I think there was some miscommunication. I have to bypass each plugin individually if I am using external gear in one of the slots in order to get the effect of just hitting the master section bypass. I can’t individually bypass the External Gear plugin and then hit the master bypass to bypass all of the other plugins in the chain all at once. Doing so will cause the same lockup and crash of Wavelab. This makes it impossible to do quick comparisons and is obviously very cumbersome the more plugins that get used in the chain.

Any idea on when this issue will be fixed? This is still a big issue for me and I’m sure many others. To me the workaround doesn’t fit in to my workflow.


I’ve just verified that the proposed workaround does NOT work. Even when individually bypassing the external gear, Wavelab still locks up and crashes if the plugin after external gear introduces any latency.

Please understand where I am coming from, I’ve purchased this product and to date I have been unable to use it. It is extremely frustrating. Any information on when this will be fixed would be greatly appreciated. Thanks.

Even when individually bypassing the external gear

As explained previously, do not use the Bypass function on this plugin.
What you can use, is the On/Off switch (see picture).

Sorry for the confusion. It my few minutes of testing that does seem to work as a workaround.

I have asked the question a few times now, when is this issue going to be fixed?


It my few minutes of testing that does seem to work as a workaround.

What happens then?

The next update is 8.0, and not before several months.

I’ve tried this in a couple of different scenarios. It’s not optimal, but it does work and Wavelab does not crash. I haven’t went through a full mastering project yet, but I’ll report back if anything changes. Thanks for your help.

So I guess by your answer you are saying that the fix for the bug will be in Wavelab 8. That’s a little disappointing.