External Gear Plugin flips phase of recorded material

master section with external gear plugin.tiff (258 KB)
master section with external gear plugin.tiff (258 KB)

I´m experiencing that using the External Gear plugin on the master section in the Audio Edit window is flipping the phase 180 degrees on both L & R channels of the recorded material. I´ve double checked that my signal chain isn´t causing the phase flip. I´ve opened the same songs in Pro Tools recording throught the exact same DA - analog gear - AD chain. This produces normal results.

It seems that somehow the External Gear plugin is causing the phase to be flipped on the recorded material. I´m using a few plugins before the external gear plugin, but nothing that is flipping the phase.

I see that the phase of the recorded master is flipped compared to the original mix.

Now I´m having to process the result with Invert Phase to get it to be right. Please help as this is really strange! :open_mouth:


George T

I managed to find a temporary quick fix. I´m putting a Stereo Tool after the External Gear plugin, flipping the phase on both channels back to normal again. Shouldn´t have to do that though:/ Philip, what´s going on with the External Gear plugin?

I´ve tried doing this without any other plugins, just using the external gear plugin in the master section, then recording the Playbacks output in the record dialog. It´s still flipping the phase without any other plugins.

Any thoughts Phillip?




I must say I have no clue. The External Gear plugin has no process that could change the phase. Maybe something at the stage of your audio driver?

Hi Phillipe

Thanks for your reply!

I´ve checked both the Avid Core Audio Manager and Audio Midi Setup in OSX. There´s nothing there that can alter the phase of incoming signals. It´s truly a mystery!

I´ve tried all possible combinations with and without plugins, recoring the input, recording what´s played back etc. It always flippes the phase.

I just opened the same song in Pro Tools again. Used the exact same DA outputs sending the mix to the same outboard, returning the mix into a stereo track with exactly the same AD inputs. 100 % the same signal chain. There it works fine. Noe phase weirdness. I´m totally confused. Is there some other process going on after my External Plugin that I´m not aware of? It´s the last plugin in the chain on my master section when I record masters.

could it be that the + and - of your analog (xlr) connectors are flipped on one side? Assuming you are using balanced connections.
It could also be an issue with the DAC, I have a Lucid 88192 converter and it flips phase on the inputs for some reason (hardware bug)


thanks for the input. I´ve checked my analog chain (DAC - analog loop - AD). Using the exact same chain in Pro Tools gives normal results. The mix passes through and returns in phase as expected. Using the External Gear plugin in the master section of Wavelab flips the phase. I´ve tried recording what´s played back in wavelab without an External Gear pluin in the master section. This also gives normal results. So I can´t get away from thinkin there´s something up with the External Gear plugin somehow. I´ve tried everything I can think of. Reinstalled Wavelab, installed a newer version of Avid Core Audio Manager (11.3). I´m using a Pro Tools HD Native card for my i/o.

Really, really frustrating! :confused:

Hi Philippe

I think I´ve narrowed the problem down. I think Wavelab is feeding my DAC with a phase inverted signal. I´ve tried just setting up a song. No plugins, just a stereo tool on the master section. Just flipping the phase on both signals gives a much better sound. It´s like the whole mix is “sucking into the speakers” because of the flipped phase of the feed reaching the DAC. Inverting both sides gives a much more correct sound. I bet this is what I´m capturing when I´m using the External Gear plugin. The signal is beeing fed (with inverted phase) to the DAC.

When I open op any other DAW (Pro Tools or Soundblade) this doesn´t happen using the very same DAC. Pro Tools doesn´t use Core Audio as Wavelab is using with the Pro Tools HD Native card I´m using.

What can be making Wavelab inverting the phase of the feed to the DAC?


I tried one more thing. I tried the same thing with Reaper. Seeing it also is using the Avid Core Audio Manager I figured it was worth trying. Sending the song through my DAC and back into the AD produces a flipped phase also in Reaper.

So I opened Pro Tools again. In Pro Tools doing the exact same thing I get normal results…so…it seems there must be something fishy going on with the Core Audio on my mac. Either that or Avid Core Audio Manager. There aren´t really ANY settings that can alter the phase in either Avid Core Audio manager OR Audio Midi setup in OSX, so how the hell do I sort this out? :confused: I´ve tried installing the Core Audio Driver that comes with Pro Tools again. Latest version. This changes nothing.

Any thoughts Phlippe?



I think there’s nothing you can do but wait for a driver fix (after addressing the maker of it with the problem). In the meantime you gave the answer in your second post: “putting a Stereo Tool after the External Gear plugin, flipping the phase on both channels”.


Thanks for your reply. I’m trying to install the latest version of OSX to see if that fixes the problem. I’ve got the latest version of Wavelab, latest version of Pro Tools with it’s coresponding drivers. Maybe a new OS will help. I had OS 10.8.5 installed.

I’ll post my findings.



Ok. So updated my OS to Yosemite. That didn´t change anything either regarding the bugs I´m experiencing. Damnit:(

Finally made some progress. I´ve found several link on forums about people having problem with the Avid Core Audio driver flipping the phase on the signal being fed to the DAC. This has been happening since way back in 2008, and still no fix for the issue. Avid needs to fix this issue.

Now that’s what I call a PRO driver… :laughing:

wow… that is indeed a strange problem. Your workaround could be the same thing that I use (in my case its the hardware) and that is flip + and - on L and R on on side of your XLR’s. Not a charming way, but it works :slight_smile: