External instrument Mutes in Project window but not Mixer and vice versa

Hi All,
Not sure if it’s a bug or if I inadvertently enabled something. I’ve created a slew of external instruments (for my analog synths) with associated midi devices. For some reason, one of my instruments has a very strange thing occurring. I can mute the track in the Project Window, but it does not mute on the mixer, and audio still plays. This also occurs with the inverse, where i can Mute the channel in the Mixer, cutting the audio, but the Mute button is not engaged in the project window. This is the only track in my entire template that this occurs on. I’ve tried to remove the track and re-add the instrument, but the issue still remains.

This also occurs with the solo button, where Solo doesn’t engage if I engage via the project window, and vice versa. However, when I solo via the project window, the other tracks are muted, and the associated outputs are solo’d, just not the track itself in the mixer.
Any assistance would be greatly appreciated.
Thanks in advance.
-A

Hi and welcome,

Do you use multi-outs on the instrument? If yes, then in the Project window, you mute the “MIDI Track” and in the MixConsole, you mute the “Audio Return” Channel.

unfortunately no. no multi-output. the only target is my stereo out. and there are no additional outputs set. It is literally identical to the 5 other analog synth external instruments i’ve made, but it does not function properly. I’ve attached a screenshot of the instrument editor showing the routing, and the inspector from the project window side by side (inspector is muted, instrument editor is not).

https://www.dropbox.com/s/mar7l8zrqoky42b/ext%20inst%20not%20muting.PNG?dl=0

Has anyone else experienced this? It’s driving me nuts!

Hi,

OUT 7-8 doesn’t sound like the default 1st output to me. Are you sure you are not using multi-outs?

Hi Martin,
I have a Madi card with 16 channels out. I have 8 stereo master outputs mapped. I used 7-8 for my Synth outputs to an external analog summing mixer. So, 7-8 is not a multi-output for the instrument itself, it is simply the outputs that the instrument is routed to.
As I mentioned, I have five other external instruments set up identically to this, and they are all functioning properly.
Thanks.
-Ari

EDIT - Is that what you mean by multi-out? having more than 1 stereo pair out in the audio connections set up? If so, why do all of the other instruments function properly, just not this one.

Hi,

Yes, this is what I mean by the multi-out.

Thank yo for the clarification. And I’m sorry to forcing you to this idea of multi-outs, because your External Instrument really works exactly the same way, as multi-out instrument.

And I will do one more try… Sorry… Open the VSTi in the Project Window’s Right Zone. Click to the arrow next to your External Instrument name and choose Activate Outputs. Can you see only one activated output here? Could you attach a screenshot, please?

Could you try to remove and recreate this External Instrument in the Audio Connections window, please?

ok, thanks for the clarification. Unfortunately it is not possible to choose Activate Outputs. The option is greyed out on all of my external instruments. Only the “Select Input” arrow is clickable. Take a look.

https://www.dropbox.com/s/w57mzuuf5phu5i1/output_disabled.PNG?dl=0

After deleting and re-adding the External Instrument, as well as deleting and readding the associated midi device, it seems to function now as expected. Mute/Solo work across the project window and MixConsole.

Literally made no change other than deleting and adding it. Same settings as before, same settings as the other external instruments. Fingers crossed it stays like this.
Thanks for the assistance.
-Ari

Hi,

That makes me creasy!

I’m glad it works after removing and recreating the External Instrument. Hopefully, it will stay like this.