External MIDI control GONE since Cubase 6 update? WTF?

Has anybody else had this problem? Cubase 5.5 works fine. Cubase 6? Forget it! Can’t figure it out…

Problem: I load up a VST and can’t trigger it via external keyboard connected by USB. The transport bar shows the MIDI signal being received when I tap on a keyboard key and I’ve tried another keyboard controller and the same thing-as in, nothing. Saved and closed a project in C6, then opened with C5.5 and everything worked as it should-any VST I opened generated sound when it received the MIDI signal from my external keyboard. Went back to C6 and the VSTs were soundless again. All audio interface settings were exactly the same in both C5.5 and C6. Other DAWs such as Presonus Studio One and CW 8.5 work without issue. Is there a setting that I have to change since upgrading to 6? Any help would be greatly appreciated.

Many thanks,


If the transport bar shows midi activity then it shouldn’t be too hard. Is the midi input port of your VSTi set correctly? Test with “all midi inputs” to make sure.


Nah man, the midi channel routing is correct. Been working with Cubase since 3.6 (before SX, I mean). It’s either a new feature setting buried deep in menus of C6 or it’s a bug. The same project opened in C5.5 plays VSTis without issue. If I save a project in 5.5 and reopen in C6, the VSTis will not receive the signal, even though it shows in the transport bar that Cubase is receiving a signal. Stand alone versions work fine too. Annoying, to say the least. Might have to go back to C5.5 or move to a new DAW. Maybe this is a sign to move on and try something new :laughing:

Have you hit the monitor button on the appropriate track?

Using external keyboard here ok.

How about temporarily moving your prefs folder to a new location and see if there’s something wrong with that?
The only thing I can think of is if you’ve accidentally activated midi filtering for notes.

Or the MIDI thru setting…