External MIDI not triggering instrument

I have Cubase Elements 10.0.5 Build 72.

For the longest time I have never had any problem playing or recording the VST instruments using my external midi controller (Yamaha P200). The other day I was playing and it was working fine until I tried to record. As soon as I toggled the record enable for the instrument and hit the record button it would no longer play or record notes. All the while I can see the “MIDI In Activity” indicator in the bottom right flashing away as I played. Turn off the record enable and the instrument started playing again, but obviously it wasn’t recording.

Next day I tried again but this time it won’t play any instrument, even without the Record Enable toggled on. The “MIDI In Activity” light flashes as I play but no instrument is played.

I haven’t changed anything on the external keyboard and I can see the “MIDI In Activity” light flash as I press a note and flash again as I release it so it’s registering note on and note off messages.

I had not touched the preferences recently. In fact, I’m not sure I ever really went in there and changed anything from the defaults. I tried resetting the preferences using the shift-ctrl-alt startup feature and I’ve uninstalled and re-installed the software but still the problem persists. I tried an update to a newer build too.

Does anyone have any idea what else I can do to figure this out. Is there something corrupted somewhere, maybe in the registry or a settings file that doesn’t get removed when you uninstall. Are there preferences I can toggle on or off to try and kick it into life.

Andrew.

Hi and welcome,

Double check Preferences > MIDI > MIDI Filter. Make sure Note is not filtered out, please.

Under the record section all options have the check mark on them. Under the Thru section only the SysEx is checked.

Hi,

Only SysEx should be enabled (to is enabled by default). When the option is enabled, it means, the data is filtered out. Disable them, please.

Ahhh, That didn’t actually make any difference but, whilst in there I did notice in the channels section below the [1] channel was slightly whiter than the rest. Clicked that and all is well again. No idea how that got selected since I don’t ever recall going in there before. Corrupt preferences file perhaps.

The difference between selected and not selected for those buttons is a little bit too subtle in my opinion. Very hard to notice the difference.

Anyway. Many thanks for your help. I can play and record again.

Andrew.