External Plug-ins section missing from the VST Effects menu

I have a Digitech TSR-12 external effects rack unit that is connected successfully to my computer. I can send sound to it via my external audio device (a Focusrite Scarlett 6i6) from YouTube videos etc.

I now want to use the DigiTech unit as an external FX unit from within Cubase.

I downloaded Cubase Pro 10.5 and re-installed it today so I have the latest Pro version.

Here is the problem I have in Cubase: instructions (found here: https://steinberg.help/cubase_pro_artist/v9/en/cubase_nuendo/topics/vst_connections/vst_connections_external_effects_adding_t.html) say to “Select an external effect from the External Plug-ins submenu” BUT there is no External Plug-ins section in the drop-down menu. How come it is missing and how do I get it to appear as an option?

I’ve attached screen shots that show:

Has anyone had this issue and how do you fix it?
Missing.jpg
Expected.jpg

Hi and welcome,

Sorry, I don’t see the issue on the screens. The Missing screenshot is the same as the expected one.

If you are missing plugins, you are maybe not in the default plugin collection?

Martin, you are right. The “Missing” and “Expected” images I uploaded are identical. My mistake.

Attached now is the correct image showing the problem - “Missing2”. In the list, after “EQ” there is no entry for “External Effects”.

This list is the same in every place I know of in my project: the Inserts section of the Inspector, same in the Channel Settings Inserts section, the Effect dropdown list in the Add Track / Effect FX track etc. “External Effects” is simply missing. The entry I want, “DigiTech”, is not ‘hiding’ any where else either. I’ve expanded all the entries and it is nowhere, nor can I find it via the search.

Ideas?
Missing2.jpg

Hi,

I would say svennilenni was right. As I can see, this is plug-in collection names VST Effects, which is not the default one. The default collection, where you can see all plug-ins is named Default.

On the right side of the plug-in list click to the arrow (Plug-in Collections and Options) and switch to the Default plug-in Collection. Or add your External Effect to the VST Effect collection in the Studio > VST Plug-in Manager.

Thanks svennilenni and Martin. That has fixed it. I’m pleased.
I’ve attached a screen shot of the fix (Solution.jpg) in case this helps someone else.
Problem solved.
Solution.JPG