External SSD causes Groove Agent 5 stutter and audio dropouts

Hi!

Issue

Groove Agent 5.1.20.213
OS: Windows 11 (Build 22621.2861)

I’m experiencing a problem with Groove Agent 5 on Windows 11.

The VST and Standalone app are installed on the system drive.

The content stored on an external SSD drive (Samsung PSSD T7) is causing visual stutter, such as freezes DAW GUI up and slows down button click actions for some milliseconds and occasionally audio dropouts especially while looping a section.

This behavior starts after opening Groove Agent 5 GUI and/or loading/playing a kit inside a host (not only pre build kits but also custom kits or drag n drop samples from SSD drives root directory or sub-folder as well). This issue perseveres after closing the Groove Agent GUI.

Disabling the Groove Agent instance does not help.

The only way to go along with this, is to load an instant of Groove Agent 5 on a track, edit it, close and reopen the session/project and not touch the Groove Agent GUI again.

As long the GUI is not visible once in the active session, there is no issue.

Otherwise i can find no way to avoid stutters and audio dropouts, other than to delete the track Groove Agent is inserted.

The standalone version has no such problem, if i am recalling correctly.


Solution

Move all the content i use for Groove Agent to an external HDD instead. Unfortunately, I don’t have a clear explanation for why this works; I stumbled upon this solution through trial and error.

An old Toshiba Stor.e USB3.0 drive with only 5400 rpm suffice for my workflow (1 instance having 4 engine fired up and around 60 to 100 samples loaded), sure i get some disk overloads, but it does not disturb the flow (no artifacts). No additional setup is needed (default Groove Agent options are in place). I see this as a quick fix. Also i do not store other libraries on this HDD. Sure other files but none that is streaming simultaneously to a DAW.


Testing

Luckily i have an embarrassing abundance of VST instruments and samplers and some of their libraries are stored on the same SSD drive as the Groove Agent content was originally.

So i stress test Groove Agent and other instruments in different DAWs (Nuendo, Ableton Live, Bitwig Studio) and got no issues what so ever with the other instruments and libraries on this particular drive. But every single time Groove Agent destroys the session, so i can confidently say that it is a Groove Agent only issue. The interesting thing is that neither the task manager/NVIDIA performance monitor nor no DAW CPU monitoring shows any (unexpected) overload during the testing.

After some time and testing, I began distributing the content to different disk drives. In the end, using external HDDs proved to be the best solution in this situation and within a short time frame.

if you run into a similar situation, this could help out you out somehow, at least to exclude a source of possible issue.

Cheers

1 Like

I’m on a macbook pro M2 max and I’ve very recently, for the first time ever, had a similar issue with Groove Agent struggling to stream. No graphical issues, but the disk cache indicator filling up and going into overload, leading to audio dropouts in the drums. About sixteen stereo drum tracks, no other tracks, and all of them bounced to audio, not MIDI. Like you, the app on my internal disk and the content on an external SSD. I ran a well known mac cleaner (Clean My Mac X) on the external disk and (fingers crossed) that may have solved the cache overload for now. So, may be completely unrelated to your issues but I couldn’t help be interested in your post given that this is the first time I’ve ever had an issue with cache overload on playback myself. I’m on Cubase 13 and this happened after upgrading to 13.0.20.

Steve.

I have the same issues as the OP after updating Nuendo 13 to version 13.0.02.
(Groove Agent 5.1.20.213). It also happens on GR5 LE.
The Standalone version is not affected as far as I can tell.

I am running W11 with all the latest updates and storing the GR5 and add on content on an external Crucial X8 2TB SSD. I also have my Spitfire libraries stored on the same drive with no problems.

I will look into it later today and maybe transfer the content on to a redundant/spare HHD I have .

EDIT:
Okay, my problem is solved. I moved the library onto another external SSD. All working fine. The other external drive is also an Crucial X8 2TB SSD.

The funny thing is; the rest of my Steinberg libraries (Absolute 6 and other Steinberg Instruments as well as my Spitfire libraries are working okay). For piece of mind and just in case I have a failing SSD drive I will move those over as well. If my problem is/was identical to the OP’s, maybe it does not have to be a HDD to solve the problem, possibly another SSD will be okay.

Thanks to OP for bringing this all up. I started to avoid using GR5, and I dearly like GR5. So, all good for me at the moment.

:grinning: :+1:

Hi Steve,

“More money, more problems,” right? Nah just kidding – the MacBook Pro M2 is an excellent unit! But I can relate. I bought Push 3 and was surprised to find it lacked external MIDI-sync input implementation, even though Ableton provided the physical connection… A 2K device that can’t handle basic functionality, LOL! Fortunately, they patched it in the current beta. Sorry, I digress :blush:. I’m glad the cleaner app did the job for you. I haven’t had much experience with such tools, to be honest.

Just one follow-up question: when you mention that you’ve printed the audio onto Cubase tracks, why is Groove Agent still playing a role in your issue? Shouldn’t that concern the stream between the DAW and the audio file storage?

Cheers,
Fabio

Hi GWC_Music,

I’m glad to hear that you’re able to run GA5 again, and keeping the content on an SSD is fantastic!

Unfortunately, using another SSD didn’t work for me. My testing included different SSDs (formatted in NTFS and exFAT) and various ports (USB-C, USB 3.0, USB 3.1), along with different cables (USB-C to USB-C, USB-C to USB 3.x), and one powered external hub.

I’m also running GA5 on another machine without any issues.

The setup is the same (OS and versions): GA5 is installed on the system disk, with content on an external SSD. This same external SSD was used to test GA5 on the machine that couldn’t handle it.

Interestingly, the machine that has no issues is overall less powerful. It also has a weaker GPU (Intel UHD) compared to the other one (Nvidia RTX Series).

To be honest, I secretly think, in my case, the issue might be related to the GPU (Nvidia RTX). Steinberg acknowledged problems with GPUs, but the issues they mentioned and the methods they suggested to solve these problems caused all Steinberg plugin GUIs to behave erratically on my system. (You can check out the link if you’re interested: Steinberg Help Center)

But after a 13-hour work shift, I only had one hour to investigate this issue and half an hour to write this article, at 2 a.m. :ghost:

So, I decided to title this article the way I did because “problem: SSD, solution: HDD” sounds simple and offers a solid temporary fix, at least for me.

Cheers,
Fabio

Hi mixsomeherbs,

Sorry to hear using another SSD didn’t work out.

Yes, I was aware of the acknowledgement from Steinberg regarding certain GPU’s. I did have UI and bad spiking problems on the initial version 13 release. After reading various posts on these problems I switched drivers on my RTX 4070. I started using the Studio Driver and changed a couple of things in the 3D settings (these had been suggested). This seemed to clear my problems, along with the update releases. Although, for me, possibly the GA5 problem was not related. Who knows…

Good luck
Garry

Hi Fabio,

Yes I’m sure you’re right, but what prompted me to respond was the fact that other libraries like Spitfire and Kontakt were working fine. And I’ve never ever had a problem before, even with mechanical hard disks. Oh well, to me the interplay between software and hardware is largely a cosmic mystery. Good luck and I hope your system keeps on working.

Steve