Extremely narrow bars (chord progression sheet)

B.dorico (723.0 KB)

With sheets with mainly chord symbols and few other elements like this, bar width gets extremely narrow and the layout turns into chaos.
How can I avoid this?

You have the Layout Option already set to hide bar rests, so there’s no need to use Starts Voice/Ends Voice to hide the rests in the empty bars. Using Starts Voice/Ends Voice (or Edit > Remove Rests) in a passage with only one (empty) voice results in there being nothing for Dorico to space, meaning squished bars.

Unset the Starts Voice property on the first slash in bar 11.

1 Like

Thanks a lot pianoleo, I’m kind of newbie and don’t know what “Starts voice/Ends voice” is, but now the full score looks OK.
I still don’t know what to do with the parts, though…

Each of the first notes in bar 11 (for flute, alto sax and piano) have the Starts Voice property turned on.

Turn it off for all three and that should fix both the score and parts.

1 Like

Thank you, now flute and alto saxophone have been fixed, but piano part looks the same as before… :smiling_face_with_tear:

You’re right.

From the Score layout, go to Layout Options, ensure that the Full score layout is selected in the right side of the dialog, then turn Bar Rests back on (from Players > Bar Rests and Multi-bar rests). Apply and Close.

Grab the rest that appears in the piano staff at bar 6 and turn off its Ends Voice property.
Grab the rest that appears in the piano staff at bar 15 and turn off its Ends Voice property, too.

Then go back to Layout Options and turn off Bar Rests again.

With any luck the score now looks like this:

and the piano part looks like this:

If you’re unsure about Starts Voice and Ends Voice, it’s probably the result of using Edit > Remove Rests without understanding how that works: Remove Rests sets those properties on the notes and rests either side of the passage whose Rests it’s removing. In early versions of Dorico those properties existed; Edit > Remove Rests was added as a timesaver but uses the earlier properties to achieve the same result as doing it by hand.

Alternatively it may be that you’ve imported in some funky MusicXML, in which case you might consider going into Preferences > MusicXML Import and unticking the Rests > Rest visibility option. This won’t fix this file but will prevent this from happening the next time you import MusicXML.

1 Like

Thank you pianoleo, I really appreciate your help.
Now the score is tidy and I learned a little more about layout in Dorico :blush:
The original file was from a MusicXML file from Sibelius :face_with_raised_eyebrow: