F1, F2, F3 keys not working.

The strangest thing has happened. For some reason, my Function keys are not working at all. They used to, but then suddenly they just seem to have stopped. I’m wondering if I may have accidentally turned them off? Is it even possible? If so, does anybody here know how to turn them back on, please?
I use the F2 and F3 keys a lot and now having to use the drop down menus just interups my workflow.

If anyone can help me, it would be greatly appreciated.

Thanks in advance!

Jermykeys the hopelessly lost! :wink:

If you go into File/Key Commands and click in the Type in Key field and enter F2 etc. does it say it’s assigned to the Transport? If not maybe your key assignments have gotten corrupted. You could try resetting to the defaults, but you’d of course loose any custom Key Commands unless you’ve saved them as a preset.

Do any Key Commands work as expected?

Some do. Just not the function keys it seems. I don’t have any custom keys set up so maybe I’ll just try the re-set. I assume it automatically goes to the defaults. Thanks for helping!

I just tried the re-set but it didn’t work. Hmmmm.

Does your computer keyboard have “alternate” function keys (not the Alternate key on the keyboard), sort of like laptops, tablets or a number of wireless keyboards has, perhaps?

But if you go into Key Commands and enter say F2 in the field does it show up there as F2 and if it does, is it assigned to anything? If as Electrobolt suggests the physical key is transmitting something other than F2 it should show whatever that is in the field instead of F2.

I’d also avoid using F1 to debug this since it is tied to help and will bring help up if used in the Key Commands dialog.

So, the problem is solved and I would truly like to thank all of you for all the great ideas! You all are awesome! However, the problem was one created only by myself because of my sheer ignorance and, well, let’s just called it for what it is. Stupidity!
I have a Microsoft Ergonomic computer keyboard. It has an F Lock button up at the top. It also has a bucket load of buttons but I’ve never used them for no better reason than, well, I’ve never really paid all that much attention to them. I bought the keyboard because my wife has one and it is simply the most comfortable one I’ve ever used.

Now, down on the hand rest, in the middle are a column of 4 green leds. Usually only the top and bottom are lit but today I just happened to notice that the bottom one was off. Upon closer inspection I saw an uppercase F in a box beside the LED. Hmmm I thought. Wonder what that is? Thought about it a bit more and came to the conclussion that it had something to do with my “F” keys not working. That’s “F” keys even though I was thinking Effing Keys.
Looking closer I found the “F Lock” key. Pressed it and my LED came back on. Went to Cubase and lo and behold, The Puppy Works!
Of course, now I feel really stupid. But that will pass quickly because I’m old and senile! :blush:

Once again, thank you all very very much for your patience and help!

Jeremykeys the apparently quite blind!

We’ve all had those duh I can’t believe I missed that moments. :unamused:

Glad you figured it out

I had the EXACT same problem (microsoft ergo keyboard with button accidentally flicked) and your post saved my life.

thanks. :smiley:

You’re very welcome! Glad I could help.

What a great 1st post!!! Gotta luv this place.

BTW
on Mac here and my ‘F’ keys have NEVER worked properly.

Laptop or desktop. So I gave up on them a loooong time ago.
{’-’}

Yup, this place is good. I use the F keys for quick navigation. Generally only the first 3 though. I’, not really much of a power user yet.

I have just gone to Mac after using PC for my whole life. So, a few things I am trying to figure out. The F Keys Don’t work in Cubase and bring up OSX features. That is, unless I press and hold the FN button followed by whatever F key I want to Press (F3 for Mixconsole for example). Is there a way of not having to press and hold the FN key down or is this just something I have to live with?

Cheers

Jono

Wish I could help but I’m running a PC. Sorry and good luck!

Go to System Preferences and search for ‘keyboard’. There is a pref in that panel for this function.

Bloody marvellous! As simple as that! Loving the Mac more and more. Can’t believe I haven’t moved sooner. Not one crash yet! :slight_smile: