Fades on Musical Mode audio events trigger glitches

Ditched my PC for a 10-core M1 Pro MacBook and the glitches are still there.
Now I’m going to pay for a Cubase 12 upgrade and there won’t be any difference, right?

1 Like

Weird… I notice glitches with Musical mode on… but I don’t (didn’t) think fades had anything to do with it. Also contrary to other reports, a quick bounce gets rid of it. (locking in the time stretch)

For what it’s worth, I’m getting glitches (specifically, high frequency pops) at the beginning of some audio events as well. Haven’t yet narrowed down the context/cause. It’s not in the sample itself because (a) this only happens when exporting the song, but not when playing it back “interactively”, plus I’ve got a fade-in at the beginning of the sample to prevent pops. Removing the fade in doesn’t help, and the audio event isn’t transposed, stretched etc. either.

1 Like

Hi,
I have tested your issue thoroughly and I’ve found the following (I’m on Cubase 12) :

  • The clip does not necessary need to have a fade as it happens without.

  • The algorithm needs to be Elastique Time or Pitch.

  • Transposing down makes it more obvious but it also happens when transposing up.

  • The click can also be a dropout.

  • You indeed have to stop playback and press play again.
    But, you don’t necessary need to snap the cursor to the start of the clip and start playback from here, as the click still happens when you start playback in advance or late to the clip.

  • I’ve found out that the click happens slightly less than 1.5 seconds after pressing play, but for it to be audible, you need audio content to be present at that 1.5 sec mark. If there is no audio event (empty space) when it’s supposed to click, then you won’t hear it.

  • Sometimes it clicks right as you press play, and when it does that, you won’t have any click afterwards.

  • Only Transposing seem to make it happen after 1.5 sec. When I do not transpose, the only clicks I can get are the ones that I mentioned just above.

  • Finally, this particular bug isn’t a major issue, or is it? The results are so much inconsistent that it doesn’t even bother me. Little bugs like that have been there for ages.

2 Likes

I really appreciate this thorough research, and I’m hoping somebody from Steinberg is paying attention to this reproducible, narrowed-down case!

I’m not sure if I’m experiencing the same issue (I’m going to have to do a similarly thorough narrowing-down), but either way, it is a major issue for me because it results in an audible pop in my export, which means it is not usable! “Luckily”, this is happening on a personal composition, but if this were happening in [paid] client work, it would stop that work dead in its tracks…

I believe I have finally narrowed down the issue :slightly_smiling_face:
I first had an issue with Quantize which was very similar to this one. I’ve then followed up by testing this case even more thoroughly.

Here is the new thread : Phase drift and glitches with Transpose and AudioWarp Quantize

Tell me what you think.

I haven 't used Transpose or AudioWarp/Quantize in that project, so it must be something different in my case. I’ll have to sit down when I find some time and deep-dive into what’s happening to narrow down the issue, and after I’ve done so, I’ll report back what I find!

Can you eventually bounce the project and import the file back with inverted phase, just to see if everything cancel out ? Try playing the parts where it uses to makes pops.
Don’t forget to put an analyzer on the output bus because it’s not always loud enough to be heard.
Just look for what I described in Step 6 in my thread.
If you have that then this is the same issue. You may have found another way to induce it. I just want to be sure.

OK, that’s easy enough, I’ll do that and post my results on this thread!

I tried this, and the pop is still there (things don’t fully cancel out). Just for the heck of it, I also switched the algorithm away from elastique to standard (even though I’m not using it), but that didn’t help either. Any suggestions on how to work around this? If I can’t make this pop go away, the entire piece/composition is unpublishable…

Thank you for doing the phase test ! If done properly, you should only have a low level bleed and audible artefacts at the start of events. Is that what you get ? It can also make a phasing effect depending on various parameters. But again, only if you have used time/pitch processing. You say it isn’t the case.

Just to be sure, if you are talking about very short high frequency clicks, that’s probably because your events directly start or end with a high value sample. It you cut your events with the split tool you need the Snap to Zero Crossing to be enabled. This will cut the audio at a 0 sample.
If not, then you must add fades or edit manually.

I’m getting a bit of a phasing effect, some bleed, and of course that pop - but yes, I don’t have any processing on the troublesome audio event.

Yes, it’s a very short high frequency click, and having the sample start at a non-zero-crossing was my first suspicion, which is why I put a fairly long fade in onto the audio event, but that made no difference.

Do the click happen only one time and between 1 and 2 seconds after pressing Play ?

Yes, that’s exactly what happens!

I can’t manage to make it happen reliably, but the causes are pitch/time processing for sure. I’ll keep digging.
To @Martin.Jirsak : Can you eventually give your opinion about the issue ?

Edit : I’ve found an easy way to make it occur.
Cut an event in three parts in a way that the 1.5 sec mark where the click is supposed to happen is within the second part.
Select all the parts, transpose, put the cursor before the events and press play.
The particular click should happen after roughly 1.5 seconds. Just ignore the artefacts at split points. The “click” should resemble this (I’ve lined the spectrogram with the actual waveform for more convenience)

The click only happens once after a Stop state. Cycling or moving the cursor during playback won’t make it happen a second time. Also starting playback too close to the second event doesn’t seem to trigger the click.
The click may be louder with Pitch algorithms than it is with Time, but it all depends on the audio material.

I’m going to keep digging and isolate my issue as well, since in my case, this is happening exactly as described, however, it is happening with a plain vanilla audio part, no time or pitch processing involved, which makes this bug even more concerning. As I said, unless I can figure out how to make this go away, it is preventing me from releasing a composition I’ve been working on.

It turns out that in my case, the click is due to the Amp Simulator stock plugin inserted into the channel and activated. When I deactivate that plugin, the click disappears. Next step for me is to see if I can change parameters in that plugin to prevent the click since it is part of the processing I need for that track.

I can confirm that Amp Simulator can cause loud clicks.
On my part I’ve found that when playback is stopped and the cursor is placed before the event, changing amp type or tweaking drive amount will cause a click on the event’s first non-zero sample. Yes, that is very specific. If the samples values are 0, there is nothing to be amplified.
If the samples have a value other that 0, even if those values are very low (let’s say -125 dB noise), they will be amplified. Any guitarist know what even the slightest noise sounds like at high gain. Here the same happens.
The click seems to occur only one time per settings tweak, even if you stop and play again.
I’ve also got some occasional loud clicks while changing amp/cabinet during playback, but that may be caused by the plugin loading new files which creates a dropout on a non-zero crossing point.

I believe this is probably linked to an issues i’ve raised over the last few years.
Musical mode anywhere in the project brings issues…
if you have cubase on a 1 beat loop, its basically unstable, chopping glitching and skipping…

It’s been about 4 years since i have been able to work on a 1 beat loop without issues while there is a channel with musical mode involved…

Just to close out this issue from my end: I simply put a small volume automation at the beginning of audio events that exhibit this issue. For some reason, doing a fade-in using the audio event fade-in handle within the audio event itself doesn’t fix the issue, but if you add a volume automation lane, and simply put the volume of the track with this issue at zero right around where the click happens, you can get rid of it.

I’d much rather not have those clicks in the first place, but this is a band-aid that works (for me).