[FB BUG] Time Warp Tool unusable (still on 5.1.1)

Hi,

I think I’ve reported this before in the old forum, but it’s still broken and it’s a BIG deal breaker when scoring, due it’s one of the finest Nuendo features.

  1. Have a sequence.
  2. Insert some dot in the Tempo track.
  3. Use the Time Warp Tool to change that point value, wrapping somewhere to the left.
  4. The clips are not re-timed.

Anybody else?

Regards,

I will check. This is a deal breaker for me too.

Anybody has checked it?

Hi Antonio

Sorry - I’ve not had time or courage to install 5.1.1. But I will say this:

Time Warp Bug In 5.1.0 (and probably 5.1.1)

The bug works like this:

1 Double click into an audio event and enable warp mode for that audio (the crotchet button or in the media bay)
2 Do a time warp stretch. Ideally with some MIDI in sync so you can hear what’t going on.
3 After the stretch you will SEE the audio has been compressed or expanded correctly, but it does not PLAY correctly. If you compress time for example, you will continue to hear audio even after the audio event has “finished” visually.
4 Workaround: after performing the time warp, go into each audio event that was switched to warp mode, and dis-able and immediately re-enable warp mode for each event.
5 Now the playback is correct and shifted.

BUT (and this is a big BUT):

Some audio files refuse to behave themselves when you first enable time warp mode for them. It seems to depend on the origin of the audio (library, recorded, bounced, whatever). Anyway, basically Nuendo tries to guess the tempo. And gets it wrong. So in addition to the problem described above, we have another problem which is that the audio will not play in sync even BEFORE the time warp is carried out, as switching on warp mode screws the audio.

A workaround for this extra issue:

Bounce the audio. I have set up a macro to do this. By bouncing, the new files “aquire” the tempo of the project at that point.

But you still have to do the disable re-enable dance after warping to get things right.

This is all in 5.1.0. Sounds like 5.1.1 has the same issue.

Yep, that’s it. I have to try C6 to check if the bug is still present. It’s weird that you are the only one who answered this thread, I think it’s A MAJOR issue.

Has this been confirmed by support???

I’ve heard others complain but I agree it’s rather weird.

What I want to know is, why does Nuendo get the tempos wrong? What would be great is if you could have a function (or mode or whatever) whereby you force Nuendo to consider an audio file to be “at rest” in the current tempo environment.

What I mean is, tell Nuendo that the audio is currently “in time” with the grid. Indeed tell ALL audio at once, effectively switching the whole project to time warp "ready"mode. Once tha’ts sorted, we could perhaps have a time warp function that is not bugged.

I am going to report this as a bug now.

BB

Oh - support. I will get on to them.

B

No oficial statement. Weird.

Anyway, the bug IS STILL on C6, so time to send a bug repport.

What?? This is amazing.

I have installed 5.1.1. Having a total nightmare trying to use timewarp. I called Tech Support and the guy there really didn’t understand what I was trying to do at all.

He said I need to tell Nuendo what the tempo of the audio is. Why??? This makes no sense at all.

Especially if you consider that there are about 6 tempo changes in the audio I want to stretch, and they are not all on bar lines.

If I put the audio into “musical” mode, it changes length. before I even use time warp . WTF?

Listen please, Steinberg, this is a major screw up. Time warp is one of the jewels in the crown of this software and it is broken.

I will try and explain what I want:

IMAGINE THIS PROJECT:

20 bars of midi, with various tempo changes.
The midi is a mock up of a string orchestra.
A real string orchestra is then recorded, exactly like the midi. But done on a Protools rig somewhere else. As BWavs.
I import the recordings into the project, using “place at origin”.
GREAT! All sounds good. The audio is in time with the midi. The click is in time too!
Ok, now my client changes their mind, and they now want the last 4 bars SLOWER. So I must TIMESTRETCH the last 4 bars.

I should be able to do this:
1 Put the audio files in musical mode.
2 Insert a tempo event at bar 16 using time warp tool.
3 drag bar 20 to the right using time warp, and have the last 4 bars (ie 16-20) of audio stretch WITH the project. Like it did in Nuendo 4l
BUT
I can’t even get off first base. I put the audio in musical mode and it changes length!!! Nuendo is “THINKING TOO HARD” and analysing the tempo of something that is should realise already, because the audio is already sitting on a timeline, with all the tempos there already.

OK I try my favourite workaround - Bounce. I bounce the audio. Sometimes this seems to iron out problems. But no, same result.

Tech support DO NOT understand what I am trying to do. They think I want to make my tempo match the audio. NO NO NO! I want to stretch the piece of music, tempo, bars, audio THE LOT.

What I must do now, is is the stretch tool (the select tool mode 3) and manually stretch without musical mode.

It’s MUSICAL MODE that is causing the problems. Why can the audio not be properly anchored to the project grid??

Ben Bartlett

I’ve tried bringing the project into Cubase 6 trial.

Slightly better behaved but I still have to bounce the files to get started.
And toggle musical mode on and off every time I do a warp edit for the audio to update. Really weird, and rather amazing that this is happening.

Finally, switched to Elastique Pro mode, and still had problems. After much toggling, decided to flatten everuting and see if I could get back to Nuendo. Upon flatten - EVERYTHING WAS AT THE WRONG PITCH AND WRONG LENGTH!!! As if sample rate had changed (project at 48 by the way).

Unbelievable.

If feels as if the “new engine” is not a new engine at all here. Just an additional algorithm plugged in. So all the bugs that seemed to come in from Nuendo 5 are still there in Cubase 6.

Utter show-stopper for this project.

B

it’s even worse then that.

  • have an audio event on an musical time base audio track.
  • use Time Warp tool (musical event follow) to shift the position of the audio event

result:
the audio will play in the old position, visually displaced

workaround:
mute and unmute the audio event after using Time Warp

And still no officlal response.

Hi,

thank you very much for bringing this up and discussing.
If I understand you correctly, there are two main issues that I would like to address separately.

1.) A bug where using the timewarp tool does not trigger playback updates for audio events in musical mode.
We were able to reproduce the problem in Nuendo 5, Cubase 5, and Cubase 6. Furthermore, we managed to narrow down the circumstances under which the problem occurs.
Here is a way to reproduce the issue:

  1. Have a project with an audio event for which musical mode is switched on.
  2. Make sure that the timebase of the corresponding audio track is set to “liner” (opposed to “musical”), i.e. you should see a clock symbol instead of a note.
  3. For convenience, create a tempo track to be able to see tempo events more clearly.
  4. Use the timewarp tool to move an already existing tempo event.
    Result: The playback of the audio event is not updated according to the changed tempo curve.

Let me add two remarks:

  1. The problem does not occur, if the corresponding audio track is set to “musical” timebase.
  2. The problem does not occur, if the timewarp tool is used to add a new tempo event (instead of moving an already existing one).

As a simple workaround, until we can provide a fix, I would recommend to set all affected audio tracks in your project to “musical” timebase when working with the timewarp tool in this way.

2.) A feature request for a way to activate the musical mode for an audio clip without the audio events being changed through warping.

Indeed, when an audio file is imported, an average tempo and duration in bars is guessed based on the length of the file. The results can be seen in the sample editor and manifest in the so-called “grid definition”. This often works well for material such as loops, but usually delivers incorrect results for other material.
When musical mode is activated, the audio clip is warped to fit the project grid based on the guessed tempo and duration in bars. Since the warping is based on the incorrect grid definition, the results are usually undesirable.

In Cubase 5 and Nuendo 5.1, you would have to manually correct the grid definition before activating musical mode to achieve what you want. In Cubase 6, there is a new function called “Set Definition From Tempo” which does exactly what you need. It can be found in the Audio->Advanced menu.
When you perform this function on a bunch of audio events, the corresponding grid definitions are set according to the current project tempo. That means that the grid definition of the audio clips match the project tempo. Then, musical mode is activated automatically without any of the audio events changing due to warping. From that point you are good to make edits to the tempo track using the timewarp tool or any other method.


I hope this was helpful. Please let me know if this works for you and if this covers all the issues you have described in this thread.

Best regards,

Christian

Hi Christian.

I glad you are here. I started feeling abandoned.

There are another issue you’re not tracking that affect to AUDIO and MIDI:

Easy steps to repro it:

  • Have a MIDI sequence track and an audio loop. Duplicate the audio loop. Both are in musical mode, so every clip of the audioloop is attached to the first beat of every bar and the length is quantized.
  • Use the timewarp tool to change the tempo. You’ll see how the MIDI IS NOT WARPED at all, and the audio is warped BUT the first beat is kept on its old position, so everything is a mess.

Regards,

Hi Antonio,

thanks for the heads up regarding this other issue.
I think what you want is that both, the audio and the MIDI are warped in the same way, while keeping their start position fixed on their respective musical position in the project. To achieve this, you need to make sure of the following:

  1. Both tracks, the MIDI track and the audio track must be set to “musical” timebase.
  2. From the tool selection bar, select the timewarp tool labeled “Warp grid (musical events follow)”. It can be reached by clicking the little arrow below the icon.

Does this work as expected?


Unfortunately, for this mode, the workaround I suggested for issue 1.) of my first reply does no longer work.
Therefore, I suggest a different workaround, which is less comfortable, but still better than having to touch each affected audio event individually: To trigger the missing playback update for all audio events simultaenously, you can disable and reenable the tempo track of the project. Please let me know if this works for you.

Best regards,

Christian

Hi,

Thanks for answering

You were right: in Wrap Grid (musical events follow) MIDI content follows tempo. Anyway, the AUDIO is still broken, BUT your workaround (disable and re-enable the musical mode) works, what it’s great (and quite painful in big projects).

Christian, do you have any official statement for these other BIG issue?: http://www.steinberg.net/forum/viewtopic.php?f=76&t=5469

Thanks.

Regards,

Unfortunately, I cannot help with this. All I can do is point to your thread to make sure that the right people are aware of it.

Best regards,

Christian

Thnx. Regards.