Figured bass sharp problem

Hi, I’m inputting a figured bass exercise with a dominant 9th, and Dorico 4 automatically converts the ‘9’ to a ‘#9’ (even if I input with a leading ‘!’ to try to force input). This is incorrect as the 9th is not #. Any suggestions?
figured bass 9th problem

I would enter it as n9,# This makes it explicit the C is natural (perhaps strictly unnecessary, but clear).

Thanks - I’d tried that, but I then get a natural sign, which is both odd (as unnecessary) and unwanted.

You can prevent Dorico from interpreting a 9 in the popover as a #9 by setting this option in Note Input Options:


You can avoid the natural sign by setting this option in Engraving Options:

Thanks @Richard_Lanyon - you’re right; it then automatically adds a natural sign, but I can remove that with literal input.

Essentially, some of the time period in which figured bass was used overlaps with the period in which diminished intervals were sufficiently uncommon that you might give the performer an extra hint if that’s what you really wanted (at least according to the sources we’ve been following). Dorico follows this convention by default but offers you the chance to change it.

It was useful to know why the popover wanted to put in a #, but I’m confused that the ‘literal input’ qualifier (preceding with ‘!’) doesn’t actually allow me literal input. - unless I’m doing something wrong.

Really the “literalness” of the input here is about what figures/accidentals are shown (i.e. modifying the Engraving Options) rather than what figures/accidentals are implied (determined by Note Input Options). If you wanted to use literal input, without changing any of the options, then you could start from what Janus suggested and type in “!<n>9,#”, where the angle-brackets will force the natural to be hidden