Figured it out! Duh!

I finally got my gazintas and gazoutas straight on my system. The reason why all my other audio apps and DAWs were able to receive input from the line-ins on the back of my FireStudio Mobile and WaveLab 7 wasn’t was because I had to go into the Audio Preferences panel and set the Channel 1 and Channel 2 Inputs from Mic 1 and Mic 2 to Line In 3 and Line In 4. Now it works properly. I just had to stop overthinking things and go back to basics! Although I greatly appreciate any help on the forum, I guess I really didn’t need any this time!