File association .cpr does not stick for Cubase 10

I cannot set Cubase 10 as the default App for .cpr on Windows 10. I have tried:

  1. Control Panel -> Apps-> Default Apps -> Choose default apps by file type -> “choose .cpr”
    While I can select Cubase 10, Windows reverts back to 9.5.

  2. File Explorer -> Open With … > Choose another app. This does not stick either

I tried a few other apps, and file associations can be changed, so it’s not just a Windows issue.

I have the same problem in Win 7. I tried to tweak the registry and still nothing.
If somenone has a solution please help us.

Mine changed fine using method 2.

Try changing the folder or file name where 9.5 is which should break 9.5 from Window’s perspective. Maybe it will take the 10 change then.

I had previously tried that, so let me describe what happens: When clicking on the .cpr file, the Cubase 9.5 installer fires up if Windows cannot find the 9.5 executable.

On Windows 10 starting with 1703 I believe, Application associations are handled by a new XML-based system. The problem could be as simple as two lines being swapped in that XML. Steinberg would supply the XML associated with their associations as part of the Cubase 10 install, but I cannot locate it, so maybe it’s missing.

I have the same issue coming from Cubase 7.5. Neither method 1 or 2 in the first post are working. Windows will not allow me to set Cubase 10 as the default app for CPR files. No matter which method I try, the screen ‘blinks’ once but then Cubase 7 remains as the default app.

Same here. Cubase 10 on Windows 10.

Regrads, Mikael

I usually open projects from Cubase, and eventually I save as… if you need to keep the old project name the new adding 10 or whatever you prefer, otherwise just save, it will ask to overwrite the old and it will open Cubase 10 from there on.

Just info…
This is not happening on everyone’s PC. My .cpr’s open fine with CB 10 when I click on them using File Explorer.

Regards :sunglasses:

In my case all .cpr files open with an older version of cubase (C7.5) regardless of which version I use to save the project. Even a new project created with Cubase 10 opens by default with the older version of Cubase.

I’m using Windows Home 10 - V1803 - OS Build 17134.407

I got a bit closer, but couldn’t actually resolve the issue: .cpr files are associated with Cubase.Project entries in the registry. I found two entries referring to Cubase 9.5

Computer\HKEY_CLASSES_ROOT\Cubase.Project\shell\open\command
Computer\HKEY_CURRENT_USER\Software\Classes\Cubase.Project\shell\open\command

Both have command.default = “C:\Program Files\Steinberg\Cubase 9.5\Cubase9.5.exe” “%1”

It seems as if it should really be command.default=“C:\Program Files\Steinberg\Cubase 10\Cubase10.exe” “%1”

However, the associated command.command field contains an “encrypted” field that appears to also be in use.

Changing the command.default entry to point to Cubase 10 enables Cubase10 as the default association, but loads Cubase 9.5 without any prompting.

Bottom line: something prevented Cubase 10 installed from updating the default project open commands for file associations.