File still marked with asterisk after saving

I am seeing what looks like a bug in the interaction of marker editing and file saving in the audio editor. This appears to be a consequence of my non-default audio file settings, which specify that markers are to be written to an external file but not to the header of the audio file. With these settings, if I open an audio file and add a marker, then invoke either Save All or Save (active file), the file tab continues to show an asterisk, even though I believe the .MRK file has been properly written. If I then try to close the file tab, I get the pop-up asking me if I want to save the file first, presumably because, as the asterisk suggests, the file is still thought to have changed. If I say “yes”, the file tab closes, but then if I subsequently reopen the file in the same WaveLab session, it opens with the asterisk on the file tab! However, if I say “no”, then reopening the file does not produce an asterisk on the tab.

This is WaveLab 10.0.40.

I think the bug is harmless, in the sense that the correct data is being written in the correct places, but it certainly is confusing.


With what file format?

Apologies for the delay in responding.

The audio file is mono .WAV (44.1/24). Is there any other information that would be useful, or experiments that I can try to isolate this better?


Philippe, I can no longer reproduce this problem. It happened after a long editing session, so I’m not sure what else might have caused it, but until I can reproduce it, don’t waste your time on it.


OK, I think I now have a reproducible protocol for this bug.

Preferences: Write Markers in Separate File is checked, and both options for Write Markers in WAV file headers are cleared.

Open a stereo WAV file. (Mine is 44.1/24, but I don’t think it matters.) Select an interval and create a pair of Region markers around it. An asterisk appears on the file tab, as it should. Close the file tab – the “do you want to save?” prompt occurs. Say yes. Everything appears to go normally and the file tab disappears from the audio editor. Now reopen the file. An asterisk appears on the file tab.

Following the same protocol on a mono file doesn’t have the bug, curiously. Neither does turning on Write Markers in WAV file headers.


Thanks. I can reproduce with one more condition: the audio file must also be used inside a montage which is opened in WaveLab.

Interesting. I don’t appear to require the additional condition. (I just tried it again.) But I’m glad that you have a reproducible instance, even if it isn’t identical to mine.

This will be fixed in 10.0.50