Filter aftertouch on record now working?

hi guys!

im trying to filter out (so basically block) Aftertouch from my master keyboard.

There is a setting: MIDI - Midi Filter - select Aftertouch in record options

this does not filter (block) aftertouch when i record.
i have to manually delete all the aftertouch for every recording.

any help with this?

im using a Minifreak keyb from Arturia, nothing in the manual

Hi,

Does your keyboard send out Aftertouch or the Poly Pressure? I would recommend filtering it out also on the Thru side, to hear the same result already when you play back (and practicing) before the recording.

1 Like

OMG you are AWESOME

it was Poly Pressure,

but it showed up as aftertouch in the list

thanks!

hi Martin, it seems the problem has returned and i dont know how to fix this…

ive attached a screen of what is happening:

to recap:

Im using the Arturia Minifreak as master key.
I record a midi part/events, but i dont want to record aftertouch.
I see controller changes showing up in all the parts in main window.
When i go into key editor, i see the aftertouch.
ive muted everything in settings except Note and Pitchbend, and i still get aftertouch when i record

is there a way to block this?

Hi,

Do you record in the Project window or in the Editor. It shouldn’t make any difference, I’m just asking to be able to reproduce it.

Hi,

in the project window

Hi,

Do you use the All MIDI Inputs option or a dedicated MIDI Input Port? Could you attach a screenshot of the Studio Setup > MIDI Ports Setup window, please?

here ya go

and yes, its set to ‘Any’

Hi,

I don’t see the Mackie Control device anymore in the list.

im not sure what you mean…

do i need the Mackie Control device?

im using the Mini Freak, does that matter?

Hi,

I’m sorry, I mixed 2 threads up… Forget my previous message, please.

Could you try in the Cubase Safe Start Mode [Disable preferences], please?

yes this worked…

how did you know this?

what should i do now? i dont want to delete my prefs LOL

EDIT: now the midi filter also works as aspected in ‘normal’ mode! no idea what is going on…all is good, for now…lets see what will happen later this week/month

Could all this be a permissions thing for mac?

These new heavy notarizing requirements for apps and all its 3rd party stuff is difficult in a lot of cases.
These situations are problematic and maybe have to do with file or disk permissions:
-When i install new plugins i cant safe presets unless i create folders manually in system HD.
-Dragging audio from/into Cubase and plugins doesnt work half the time.
-Saving prefs in some plugins from big 3rd party devs is not working well.
-Some settings in Cubase get lost like Studio Routing, and i have to keep resetting these…
-etc etc

please dont get me wrong; CB 13 is freaking amazing and i can make awesome music at lightning speed…im just trying to help :slight_smile:

Cubase preferences becoming corrupt is a common source of problems.
To my knowledge, the only thing you can do is take the entire Cubase pref folder, move it to somewhere safe and start Cubase up as normal. This will prompt Cubase to create a new, default set of preferences files. From there, with Cubase not running, you can start to replace the new, default XML files individually until you found which of these is the culprit.

On macOS, preference files are stored in the following location: “/Library/Preferences//” under your home directory.

From what I’ve understood, the file most likely to give you issues is called Defaults.xml, so that’s where I would start.
If you wish to go further, you could start comparing your old XML file(s) with the default ones created by Cubase to try and salvage as much of your preferences as possible.


Lastly, I’d like to invite you to this thread if you think Cubase could use a more robust way of handling user preferences.

1 Like

Hi,

The Safe Start Mode deleted the defaults.xml file only. So if you don’t want to delete all preferences, you can delete just this file. Obviously, something is wrong in it.

yes, the problem came back this morning

i will do what you said, thanks

thanks for your input

its all so time consuming and im running on too many deadlines here

maybe its time to hire an extra engineer for these kind of jobs LOL

Hi,

Does it mean, it’s not there all the time?

When i switched to safe mode it was gone, the filter worked good

Then, the first production day the filter also worked (no aftertouch in recordings)

But yesterday, the filter does NOT work (i have aftertouch in the recording despite it beeing selected in Midi Filter in prefs)

Let me delete the prefs defaults to see if this is what causes the problems

Martin,

do preferences get saved per project, sometimes? or is it always globally

Hi,

If you just Disabled the preferences in the Safe Start Mode, you get your preferences (in this case defaults.xml file) back during the next Cubase start. You would need to Delete the preferenes.

The preferences are always global.