Find hitpoint and split event

I’d like to do something with cubase that is hard to do.
After find a hitpoint with alt+N, I want to split the event from this point with « split to locator » but, when I do this, it splits all the events of every tracks on the locator. I only want to do it on the event of the track. I try with « split event », but it doesn’t work.

For my workflow, I want to:
Find the hitpoint, split the event with one key At once.
Is there a better way to do that?
Thanks a lot

We had the question just recently, didn’t we? At least something like that. :wink:

The function splits all events on all tracks that are intersected by the locators. Always. (Unless you lock certain tracks or events for editing.)
If you want to split only certain events, then you have to select them first. (Or press ALT with object selection enabled and click on the respective event.)

Unfortunately, there is no other way. At least not that I know of.

Thanks for your answer

Create a macro which locates next hitpoint and then splits. As mentioned, make sure the event(s) is/are selected first.

If you want to do this across all hitpoints for an event simply do this in the sample editor and “create events”.

1 Like

I tried , but I didn’t manage to do it.

When I find a hitpoint, I want to split at the hitpoint.
What is the best methode? ( because I’m obligated to click again on the hipoint, sometimes I’m not precise. and after I can split.)


Hi! Why not use Alt+X Split at cursor?

Your macro could look like above. Just make sure to have the event selected.
Of course, you can open an audio event in the Sample Editor, create hitpoints there and then use the function “split to events”.

Hello, it doesn’t work with this command (alt+x) because when I use hitpoint, the event is not selected. If I select the event, the cursor goes to the event start.

Hi! Cursor goes to the event start if you have selected “Use video follows edit mode” in the Transport menu. Try to deactivate it.

Make sure “Track Selection follows Event Selection” is not ticked. Preferences → Editing

Then the key to success is to select the track that holds the events with the hitpoints but to select the event(s) that you want to cut.

Hello, thanks for your answers.

With it, it doesnt work.
I try to deselect these options but it’s the same.
For working, we need the cursor ( in the event) follows the transport bar when i press option+N for hitpoint.

I’d like to do this thing

But when I presse alt+X, it cuts all the events inside
Why doesn’t it do that in this video?

Isn’t this what you want to do?


Yes, it’s what I want to do

How do you do this?

Alt+N And Alt+X
But you say it does not work for you?

Alt+x cuts all the events on the bar transport

It works fine here. It’s something on your end Frederick. Maybe corrupt preferences?

Alt X splits the selection at the cursor position. Works with normal selections and ranges. If nothing is selected, it will split everything under the cursor.

  • To navigate hitpoints (Alt B, Alt N), you have to have the track selected.
  • To split the correct event at the position that the cursor is located, you have to have the event selected.
1 Like

Thanks a lot.
Before to find hitpoint I have to select the clip, and after that, it works. If the clip is not selected, alt+x will cut all event at cursor.

With all due respect: That’s what we have been saying for the last 11 days.


I commend your patience in answering the question. :+1:

@Frederick_Caramia: May I ask why it is such a problem for you that you first have to click on an event? I would really be interested to know.