Fireface UCX Users...

Hey all!

I want to know if you guys can check something quick and verify that you are getting input signal into Cubase when setting the Fireface UCX down to 48 sample latency. For some reason I’m not able to hear anything when I set mine to this latency, but it works perfectly on higher latency settings. By the way, I’m using the latest firmware and drivers from RME.


I use UFX and I have no problems running at 48 samples, either with USB or FW. Although I prefer to use 64 because it makes the system inherently more stable (and, in fact, the engineers at RME don’t recommend to go lower than that.) If I’m not mistaken, the UCX is basically a scaled-down UFX.

Mine seems to be fine.

Are you guys using the latest firmware and drivers for your interface though? I’m using firmware v.42 and driver v.1.034. Also, my system is overclocked (see signature below). I was wondering if you guys are Overclocking your systems as well. It may or may not have something to do with it, so I’m gonna try recording without the Overclock to see if it makes any difference.

FYI, I was able to record at 48 samples just fine before with my previous system, which is nowhere near the specs of the current one. Another thing I noticed is that changes to the Buffer Size/Latency parameter made within Cubase (in the Device Setup window) take effect immediately without needing to press OK. The behavior I remember is that I should press OK in both the Fireface UCX Control Panel AND in Cubase before changes take effect. Something’s not right here.

Thanks for the responses :slight_smile:

Latest firmware/drivers: YES
Overclocking: NO (already plenty of power for my needs, why chance it?)

I tried with stock CPU clock and the same issue persist :frowning:

I don’t have anything amazing, just an i7 950 with 4 gigs of ram from 2009. Do you think it could be your UAD cards?

OK, I’ve done a little bit of testing and got Cubase to record at 48 sample latency. However, the issue is still there and shows up randomly when switching buffer sizes. I have to constantly keep switching and/or re-opening the project to get it to work/not work. Very random stuff, to say the least. I haven’t been able to reproduce it reliably, so I don’t know what’s up. The only thing I can say, is that this behavior can also be seen in Digicheck, so it may be an RME driver issue or a system issue. Will report back if I find anything new.

OK, I believe I found the problem. Seems like the issue shows up when setting the sample rate to 48KHz, but not when the project is set to 44.1Khz. Can any of you try to replicate the problem at 48KHz sample rate? Thanks!

Tried that, still works. Maybe it’s something related to the hardware of your particular machine?

It could be. Do you have MMCSS enabled on the Fireface?

Also, I have discovered that I can’t go straight from say 128 samples to 48 samples. Instead I have to switch gradually in steps from 128 to 96 to 64 down to 48 samples in order for it to work. Thankfully, I don’t have to keep opening and closing the Fireface’s Settings page as the changes seem to take effect immediately without having to press OK. But I do NOT have this problem at all when using 44.1KHz sample rate, just with 48KHz. Matthias, from RME, suggested I try enabling MMCSS on the Fireface to see if the issue goes away. Will try that as soon as I get back from work.

Thanks for your time!

Also on UFX here (USB mode), but I get this behaviour sometimes but only on the laptop (i3 or i5), not Desktop (E8500), also with Cubase 6.5 usually at 44,1 kHz samplerate.

I tried when RME put this option back in the driver in May, promising better performance with C7. But I didn’t see any difference, even at high CPU loads. Maybe weaker computers can take advantage of that, but on mine it makes absolutely no difference whether it’s on or off. And since I also use Sonar and the Cakewalk engineers seriously advise to NOT switch it on, then I decided to keep it off.