First minutes with Dorico - Multiple slurs

Started my trial today after seeing Dan Kreider’s Youtube video. I’m a 10 year Finale user and like most of us, I’ve had my head in my hands more times than I can count. Needless to say I was excited.

I’ll spare everyone thedetails of the first hour. Right now, I’m thinking ‘At my age, with my lack of brain plasticity, can I really re-learn everything to get to the point where I’m at in Finale’? One thing’s for sure, I can fly in Finale.

So please check out the attached. I’m just trying to get the basics of note entry workflow down. I have a line of random notes written and I’m on bar 5. Notice that the last eighth rest in bar 4 is lit yellow, even though the carat and grid are ready for input at bar 5.


I enter a note at Bar 5, and a note appears with 2 or 3 slur marks over it (?) and then there’s a pause… and then I see the spinning blue ‘working’ icon familiar to Windows users… and then I get what you see in the second attachment! Pretty funky. My coffee cup isn’t pressing any keys on my keyboard. This is the result of one note entry click.

I have noticed that the slur icon is ‘pressed’ or ‘chosen’ in the menu in the upper left. I think ‘Okay, just toggle that off by pressing ‘S’ (‘s’ or Shift S)’, but that won’t work. Click directly on the slur button won’t work. I can toggle all the other buttons up there (accent, accidentals etc) but the slur button is stuck on. I can’t unselect it.

Any input (no pun intended) would be appreciated. I’m through for the night. I’m leaving this open project on my desktop, I’ll check back tomorrow afternoon EST.

Well, I just had to post this. I went back after posting the above and stared at the screen for a few moments. I stared down at my ‘S’ button and then tested to make sure it’s working (it is). Then just for fun I pressed the ‘D’ button. The result is attached! I must be doing something to cause this but what?


Yikes…

Pressing the A key produces even more wild and wonderful graphics, and the spinning blue circle that indicates ‘your computer is either working or hanging’ is just spinning away.


Pressing Ctrl + Z to try to unwind this results in a very slow unwinding that takes about 30 seconds as the unwanted graphical elements disappear in chunks.

Last note then I really have to go to bed. My computer is pretty powerful - 16 GB of RAM and an up-to-date proc. I run Cubase 8.5 Pro and Finale on it simultaneously with no issues.

Task Manager shows CPU usage at 7% and RAM usage at 28%.

Mset, have you restarted your computer since installing Dorico?

Hi and thanks for the response. I have not! Shall I try that? I will do it now. I will save this chart though, to see if any strangeness attaches to it.

Restart your computer. If that doesn’t help, unplug any midi controllers that are currently connected - I’m wondering if there’s something sending data continuously and Dorico’s struggling with it.

Well yes, that fixed the issue. Thanks again. But crucially, I think, the slur button is no longer stuck on.

But I do wonder if this was just caused by the fact that I didn’t reboot before starting to play with it? Could a lack of reboot have caused the slur key to stick like that? I can’t really recall having to do that with Finale or Cubase or ProTools or any other big program, but if this is the case I’m happy!

Now really off to bed. I’ll continue tomorrow evening late. I’ll try to run it for a few hours and see what happens.


Just saw your last. I have an Akai MIDI controller keyboard hooked up but again, no stuck keys. But yes, it sure looks like a data stream is being sent in either a burst or continuously. And a MIDI controller wouldn’t cause the Slur button to be stuck on, right?

I’ll try to troubleshoot tomorrow. Let’s see if the reboot fixed it?

It’s almost definitely caused by not rebooting. If you were installing Dorico for the first time, I’m surprised that you weren’t prompted to restart (though it may be that it’s an ignorable hint of a message rather than a compulsory “click this button to restart”).

I’ve never seen this specific problem before, and a reboot isn’t normally needed to get things like the keyboard working! I wonder whether quitting and restarting Dorico would have been sufficient. I’d be interested to see the contents of the diagnostic reports that will be created if you choose Help > Create Diagnostic Report. This will create a zip file on your desktop. You can either attach it here or email it to me at d dot spreadbury at steinberg dot de.

In answer to this point, I would say: your brain is a much more powerful and flexible computing device than any Intel CPU. As long as you think “this is a new program, and not Finale”, then you’ll pick it up quickly. I switched almost entirely from Finale about a year ago, and I would say I’m more proficient now with Dorico than I was after my first year of Finale!

( FWIW: usb attached MIDI devices (when powered thru the usb) can start emitting random bits and bytes IF the voltage drops… )

I don’t know what you did to toggle the slur button on (perhaps you accidentally hit the “s” key multiple times at some point) but please note that you can have multiple nested slurs, depending on how often this button is clicked or the “s” key is pressed. And likewise, you have to press Shift-S as many times to unselect all the slur “levels”.

The fact that you don’t see how many slurs you have activated is a user interface issue that hasn’t been resolved yet (I’ve brought this and a possible way to solve this up before but obviously the developers haven’t tackled it yet). I also found this very counterintuitive in the beginning; I’d assume clicking the activated slur button again would deactivate it, only to find out that it would add another slur, and to this day I have no idea how to deactivate this button using the mouse, I only use the S and Shift-S keys.

Double-clicking somewhere on the screen to end input mode deactivates it, but that’s a bit drastic just to end a slur!

It’s pretty great to have the lead developer here to take an interest in this occurrence! Thanks Daniel. I’m sure Occam’s Razor dictates that the issue is likely somewhere on my end. I’ll send the diagnostic report to your email now.

I will restart the exploration process after 11 pm EST and report what I find.

Okay thanks. In fact my Akai keyboard is powered by USB, however it’s not going directly into the computer but into a (fairly well reviewed) Anker powered USB hub. Not sure if that makes a difference. I do have a lot of things plugged into this hub at any given time (trackball mouse for use in Finale, Apple lightning cable, charge cables for micro-USB recharging of devices, even my Steinberg UR12 is plugged into it).

Again, though, the system seems quite stable and I work daily without issues in many programs.

Well this is quite interesting. I don’t know that it can explain the initial occurrence since I didn’t ever touch the slurs button before the appearance of the first batch of slurs. IN all honesty I didn’t even notice that the slurs button was toggled on at first. But later, I probably clicked the slurs button many times trying to get it to toggle off, and maybe that’s why the subsequent pressing of ‘D and A’ produced the results seen in the second set of screenshots.

That’s encouraging. I really (followed by several more reallys) want this to work.

mset, I’m glad the YouTube video was helpful. Have you read my Beginner’s Guide? New users have frequently said they find it another helpful way to acclimate. https://www.dropbox.com/s/6d2qmdapwqpxyn4/A%20Beginner's%20Guide%20to%20Dorico.pdf?dl=0

Thanks to all who responded. Daniel has looked at the Diagnostic Report and determined that Dorico received many commands to make a slur, which is basically good news. This would require either multiple presses of ‘S’ (which definitely did not happen the first time) or else it’s possibly an issue with my MIDI keyboard. I was not using the MIDI keyboard at the time this anomaly occurred but who knows, maybe the keyboard fired off a bunch of commands to Dorico even though I wasn’t using it.

Dan, I sent you an email!