Fix Editors Problem

Not sure if this is a feature request or a bug report.

With the Sample/MIDI editor In Cubase 8.5 and before, when I doubled clicked an event, it would bring up the editor, and only one editor. Now, in version 9+, it opens up accumulates each time I open an editor. The editors open on top of each other, so it’s hard to even tell how many I have open at a given time. Sometimes, I will find that I have a dozen or more open all at once. I feel like this has got to make it harder on the CPU, plus it’s really annoying because sometimes I think I have one editor open, when it’s really another one altogether.

Could you please make a feature where you can disable opening multiple editors of the same kind? I’m sure having a dozen different midi editors open at once has it’s uses, but it would be much appreciated if that was not the default workflow.