Fixed: Dramatic CPU usage with even very small projects

Ever since version 2.2, I am having horrible CPU overload with Dorico. I thought it was with projects that are too big, but I’m trying now with a single XML import of two cellos - 30 bars of music and Dorico is at 96% CPU usage. it creeps up over the course of several minutes until the program is almost totally unresponsive. It acts like a memory leak in that way. I have nothing in my playback engine, and all I’m doing is playing back the audio in Cubase and writing in the dynamics in Dorico. I love Dorico, so I really hope we can get this fixed. I’m on a 2015 Macbook Pro 2.8 ghz i7 with 16 gigs of ram running 10.13.6
Screen Shot 2019-06-28 at 2.07.11 PM.png

What happens if you close Cubase and run Dorico on its own?

I wonder if the two audio engines are fighting each other, or something like that.

I have the audio engine set to silence in Dorico. I need Cubase running in order to listen to the audio tracks. Someone else asked if I have a MIDI keyyboard hooked up. No-just my headphones.

Of course it should by possible to run Cubase and Dorico together.

I was suggesting you try running Dorico on its own, to isolate what is causing the problem.

The problem is only in Dorico. Dorico is what slows down. Dorico is what shows 96% CPU usage. Cubase is working just fine. To be clear this is a new issue that started with 2.2 or maybe with 2.1

Perhaps I’m not being clear about what I’m doing. I’m NOT composing in Dorico. Using Dorico by itself without cubase is useless. I am doing music preparation where I need to be listening to the cues in Cubase (since Dorico can’t play audio files). I cleaned up the midi in Cubase and exported the XML in to Dorico. I do the writing of dynamics in Dorico while listening to the cue in Cubase. Closing Cubase means there is nothing I will be doing in Dorico, so there’s not much to test that way.

There’s definitely something wrong here. I regularly have Cubase and Dorico running at the same time without problems. One initial thing to check though: try temporarily disconnecting any midi devices (keyboards, controllers) as some users have had problems with devices that constantly generate hundreds of events. If it’s better after that then we know that that’s the problem area and we can dig in more. (eg use a midi monitor app to find out the device and what sort of events is sending)

Also, does the problem happen with any project? If it only happens with one then we’ll need to take a look at it. If it’s going wrong for any score then a diagnostic report and spindump will give more information. Sorry, I don’t have the link to hand as I’m on my phone, but search this forum for spindump and and you’ll find the instructions.

No midi hooked up-just headphones.

It has happened with several projects, but they do all use the same custom template, and the only way I know to do that is by completely deleting all parts and layouts and players and flows and then resaving as a new name. So maybe something is hanging over other than that? As I said there are no VSTs loaded and I have the playback template set to “silence”.

This might be the blind leading the blind, but I’ll mention some stuff in case it might prove fruitful.

The problem may only manifest in Dorico, but to a greater or lesser extent, any application you run, including Dorico and the operating system itself, is affected by every other application you’re running. (You’d be amazed what tiny things can make an application hang or a computer crash, for instance.) Thus, Rob’s suggestion is entirely valid. I encountered an issue that sounds very similar to yours at one point, though I was running Vienna Ensemble Pro rather than Cubase. Dorico was the only application that showed symptoms (VEpro was just fine), but it was definitely a case of something wonky with the handshake between the two. Another program might or might not be the problem in your specific case, but you’ll have to test to gather more clues.

The symptoms I encountered recently were identical to the ones you describe, except that the CPU showed 2% usage. You may have a completely different problem with similar symptoms, but just in case it’s helpful: for me, resetting the SMC and the PRAM fixed it straight away. If you’re unfamiliar with how to reset these items, here’s one source of information:

Not necessarily; there is an awkward workaround you can use to diagnose (i.e., rule out) whether the problems are caused or exacerbated by running Dorico and Cubase concurrently under your configuration. Attach an audio file to a video (the visual can be just a blank black card) in iMovie. Then attach the video you created to the Dorico flow you’re working on. Make sure your preferences aren’t set to follow the playhead during playback, so you can replicate your behavior (i.e., play the “video” and enter dynamics at the same time). (Btw, I’m not sure if having your Playback Template set to silence affects audio playback, or just the MIDI playback engine. You might need to enable a Playback Template to hear the video’s audio.)

If none of the above works, you might also try closing Cubase and playing audio from any other application such as iTunes or your web browser, while working in Dorico. If you still encounter problems under that configuration, it might point to something about your audio interface or DAC being the culprit. I have occasionally encountered an issue where my RME Babyface gets “stuck” or “confused” when frequently bouncing back and forth between multiple audio applications. Sometimes it refuses to cede control to the application I’ve just switched to, and if I don’t reset it right away when I first notice it, it can eventually lead to symptoms similar to yours.

Good luck,

Hi guys. I appreciate the help. I hope that what I’m saying doesn’t sound contrarian. This is a great community, and I respect and appreciate the help.

I can’t use the video method. Since people are trying to give workarounds, I’m just going to quickly talk through the workflow:

I get a PT project from the composer.
I open the PT project that contains multiple MIDI files as well as multiple audio tracks.
I export the MIDI files as a Type 1 file.
I import that MIDI file in to Cubase because that is my bread and butter DAW. I know how to use it, and that’s where I am fast.
I create a time signature track and a Tempo track because these are film cues and time signatures change almost every bar and tempos are all over the place.
I import the audio files that correspond to the MIDI files (individual specific parts as well as a “everything else” track). This is so I can solo the individual parts as I’m listening back.
I then clean up and quantize the individual MIDI parts.
Then I name the parts correctly (so that Dorico knows what to do with transpositions)
Then I export all the MIDI as XML
Then I open Dorico and import the XML in to a new Flow. I assign the instruments to a new part so I can just keep everything isolated to that flow (cue).

Now I loop the sections in Cubase while I’m putting in the dynamics for the parts in Dorico. I solo the tracks that I need to solo to be able to clearly hear the articulations. Everything up to this point is seamless, but then Dorico gets slower, and slower, aaaannnnddddddd slllllooooowwwwweeerrrrrr.

Once done, I print the parts and deliver to the composer.

I don’t have time to mess around with creating video tracks for individual parts, etc. This is a fast job where I need to turn these cues around fast. I appreciate that people are trying to give workarounds, but the bottom line is that this workflow used to work fine, and now it is becoming increasingly laggy. I don’t know whether it is Cubase or Dorico’s fault. I don’t care. But I do know that it is Dorico that is slowing down - not Cubase, and it is Dorico that is showing the huge CPU usage in my activity monitor (not Cubase).

I’m not trying to say this is not somehow my fault-it very well may be. But if so, it’s something that didn’t used to be an issue that has increasingly become an issue.

Paul, here is my diagnostic report:

Please let me know if you see anything from there. Thanks!

I won’t be able to look at this until I return to the office on Monday, but I’ll aim to get back to you then.

If you could attach your project template (zip it up first) then that may help

Thanks Paul-can I email that directly to you? Which email? Thanks sir!

Paul’s email address is p dot walmsley at steinberg dot de.


The video thing wasn’t suggested as part of a workflow, but as a diagnostic to possibly gather relevant information which might help you hone in on the problem, or at least conclusively rule a few things out. The idea was to try it for a mere 5 or 10 minutes (however long it normally takes for the symptoms to develop) and observe if the symptoms were any different while running a different configuration.

Respectfully, unless you’re ready to pay a local service to fix it for you, saying you don’t care about the root cause is tantamount to saying you don’t care if the problem ever gets fixed. (And do bear in mind there are many other possibilities than the two you mentioned (Cubase’s fault vs. Dorico’s fault). There are many more possibilities than all of the ones everyone has mentioned! I’ve had enough bewildering computer problems over the years, especially when running multiple applications that have to talk to each other, that I’ve learned the hard way to be very cautious about ruling things out in my mind without physically testing them. Many times I could have reached a solution several days earlier, if I’d just taken the time to physically test things rather than assume they weren’t relevant.)

Did you take 5 minutes to try resetting the SMC and zapping the PRAM? If so, did it make zero difference, or was there a temporary improvement before the symptoms returned?

The more clues you can gather, the more experiments can run even if you think they’re probably not relevant, the better chance you’ll have of fixing the problem without paying someone.

When you finally find a solution and after you meet your deadline, please be sure to post details about the solution here. That way if someone encounters similar symptoms in the future, you might save them the several days of headaches that you’re unfortunately going through.

Hope everything gets fixed soon.

Sam, You have more patience (or less life experience) than I have.

I decided I was talking a different language from the OP (though they both superficially look like English) after post #5, and the most rational response was just walk away.

There are plenty of questions here from people who do have a constructive attitude, without spending a lot of time on the minority!

Hi Mbira

I’ve been having similar problems with my similar setup. I haven’t got any useful technical information, so please excuse any naivety, but I suspected some time ago that there is a conflict between these two Steinberg programs, Dorico and Cubase, because they share the same resources. Could it be associated with, for example, the Halion Player which is the default player for Dorico? Having said that, when I use NotePerformer instead, the problems don’t go away.

Like you, I’m looking forward to a fix for this otherwise incredible and evolving program.

It’s interesting and sad to read that it sounds like you took something personally here.

For me the bottom line is that I need to use a multitrack audio program at the same time that I am using Dorico. I have been using Dorico and Cubase in this way since the beginning. This is a new issue. Solutions or recommendations that involve only running Dorico are not useful for me. It’s nothing personal. We all use Dorico in different ways. Have a good day.

Thanks for your well wishes. I will be sure and post here when a solution gets worked out-regardless of the underlying cause.

Thanks so much to the help from Paul Walmsley- he found the issue! I have some IAC midi drivers that I use with external midi equipment, and even though I don’t have any of that stuff plugged in, it turns out that when I import the MIDI files in to Cubase, it was creating IAC output connections from the MIDI tracks and that was getting picked up by Dorico. Solution: In my case, I have no need for the IAC to be read by Dorico so I disabled those in Dorico, and I’m back up and running. Thanks again Paul!