[FIXED] Hub not connecting - Crash on exit 9.5.10 Mac OS

This is solved. Cubase hang on quit, caused by hub not connecting. Removing preferences fixed it.

Every time I close Cubase it just hangs, so I have to force quit the application.
Cubase 9 runs perfectly, and has no issues whatsoever on the same machine.

It isn’t related to any project or anything… even if I quit Cubase 9.5 before opening a project it’ll hang.
Unfortunately I can’t tell if this is a new issue with 9.5.10, since I didn’t have time to use 9.5 much when it just came out.

For example:
I launch 9.5.10 to the hub…close the hub, and quit Cubase. It’ll freeze and I am forced to force quit.
The exact same thing in Cubase 9 works perfectly.

I run Cubase Pro, but I don’t know if that has any significance, and there’s no blacklisted plugins in either 9 or 9.5 for me.

OS is High Sierra 10.13.2 and I am running it on a Macbook 12".

Does anyone have any ideas on what to try? Or how to troubleshoot this? It is rather annoying.


Hi and welcome,

Could you try to remove the Steinberg Hub component, please?


Sure, but how do I do that?

Btw I did also confirm that Cubase Elements 9.5 work just fine. It can quit from hub without crash.

edit: To clarify. It isn’t the hub itself that makes it crash.
If I quit from an open project it crashes too.
The hub example was just to point out that it wasn’t anything to do with whatever plugins I may have had loaded.
Also I can close the hub itself with no issue when I launch Cubase. It is when I go to actually quit Cubase itself that it freezes and I have to force quit the application.

Again this all works fine in Cubase Pro 9 and Elements 9.5.10. In Pro 9.5.10 it freezes.


Open Applications folder. Right-click to Cubase 9.5, and select Show Package Content. Then open Contents > Components and move hubservice.bundle to your desktop.

Start Cubase now.

You says, it crashes even if you quit from Open Project, but the Hub has been already loaded and it could already make something faulty in Cubase. So lets start with the Hub, please.

Could you share the *.crash file (located macOS Console utility), please?

Well damn… that worked!

Now what though? How do I go about getting a hub that works? :smiley:

I put the hub component back and share the crash log?

I just noticed something interesting. The hub doesn’t actually connect on 9.5 for me… it’s just stuck at connecting forever, whereas on Cubase 9 it loads just fine.
Amateur guess here…but maybe that’s the process that hangs causing it to not close properly?
No matter how long I leave the hub open it wont connect on 9.5… (also I can’t find the crash logs int he console utility… )

OK, if it hangs, but it doesn’t crash, then you cannot find a crashlog.

Could you try to copy the Hub component rom your Cubase 9 application to Cubase 9.5? What happens then?

The 9 hub component made no difference. It’s still stuck at “Connecting…” and the same hanging behaviour happens when I try to quit.

Do you use any antivirus or firewall which could block the communication with the Steinberg server?

Nothing of the sorts. Also it does work just fine on Pro 9, and Elements 9.5, so it’d seem strange if 9.5 was communicating with a different server.

If there would be a antivirus or firewall, it could block one application only. Could you make sure the Firewall is switched off in the System Preferences > Security & Privacy > Firewall, please?

Could you try to use the faulty steinberghub from Cubase 9.5 in any other Cubase version (Elements 0.5 or Cubase 9)? But actually I don’t think it’s in the component.

Firewall was turned off.
“Broken” hub component from Pro 9.5 in Elements 9.5 worked just fine, so no most likely not the hub component.



Could you try to trash Cubase preferences? And reinstall Cubase?

Alright where do I do this? The preferences? I did reinstall 9.5 before, and when I did that I only removed the Cubase 9.5 under Applications. No idea if this is enough or not. I can redo it.
I can, btw, confirm that 9.5 Pro works fine on a Macbook Pro I got here on my network, so it rules out any router issues as well.

Preferences on Mac: ~/Library/Preferences/Cubase 9. Rename this folder to _currentDate_Cubase 9.

Start Cubase.

Or search Google for Cubase Safe Start Mode.

Hi again,

Took a while to find Library folder since it’s hidden. Anyway, killing off the preferences did fix the problem. Still curious to see what caused this, as it could be useful for others as well.

Thank you!


Could you share the *.crash file (located in macOS Console utility), to be able to resolve it, please?


I thought we concluded that there was no .crash file since it was just hanging due to not connecting.
The error clearly lies in something with the preferences, but since no crash… who knows?
Whatever preference file handles the hub connectivity is probably where to look, but I dunno which that might be.
I am just using the new generated preferences now since that fixed it, but again… I am still curious what caused it, and steinberg should be too :smiley:

Sorry, I just read the thread name and the last comment. And I forgot the whole story in the meantime.

If you are interested, you can copy dedicated files over from the old preferences folder to the new one.