FIXED - Pops and Clicks on Playback

Hi All

I’m really hoping you can help me with this, I’ve been trying to solve this for a couple of days now. When I playback in Cubase 7, after anywhere between 1 or 2 seconds and up to a minute I start getting weird pops and clicks (I’ve attached a link to a soundfile so you can hear it to - the pops are towards the end).

I’ve been tinkering with buffer size etc and lots of other settings - but nothing is having an effect. Could anyone on here please advise me what this could be?

https://soundcloud.com/jonsteadmancomposer/pops-and-clicks

thanks - Jon

Windows 8 (64bit) i7-4820k CPU - 8GB RAM - Cubase 7 - M-audio NRV10 Firewire I/O

Hey Jon,

any programs running in the background that might use a lot of CPU power?
You also want to try a tool called LatencyMon - it might help you to identify the problem.

thanks for the reply -

The PC is brand new - so there’s no software running in the background. In fact I did a screen capture of the task manager when the pops were happening during playback and the CPU was running at 2.8% (although the performance monitor in Cubase thought it was running much hotter than that) and the RAM was being used by only 25%

I ran latencyMon - it suggested my antivirus was causing hard page faults so I disabled that - but it made no difference. Interestingly just running LatencyMon caused masses of pops and clicks - constantly during playback in Cubase.

I’d welcome any other ideas - thanks for your help with this - JS

Hi. Few things.

  1. What is your buffer setting, and how high did you set it?
  2. What piano is this (important)
  3. I didnt hear any clicks until the vocal came in - that correct? What plugs/processing do you have going on there?
  4. You say Pops and Clicks on Playback - is this a Cubase export, or did you play the transport, and record using Audacity, or something similiar?

Hi Jeff - thanks for taking the time - I’ve put some answers below

  1. What is your buffer setting, and how high did you set it? Currently 512 - but I tried it all the way up to 4096 and yet I get the pops and clicks broadly about in the same place.

  2. What piano is this (important) - Halion Sonic SE which appears to be sucking enormous amounts of CPU for some reason, but I do get the clicks when I take all VSTs off and play just audio files also.

  3. I didnt hear any clicks until the vocal came in - that correct? What plugs/processing do you have going on there? That was just the timing that time round. I’ve tried playing the song with vocals channels muted - and I still get the pops and clicks (at some point or another within the 1st minute)

  4. You say Pops and Clicks on Playback - is this a Cubase export, or did you play the transport, and record using Audacity, or something similar - It’s a Cubase export

thanks again

Make sure Wi-Fi is turned off.
Also, try turning on Steinberg Audio Power Scheme (SAPS).
J.L.

I seem to remember that Steinberg recommends that you don’t use SAP under Windows 8. There is a KB article which I will try to find and add to this post. Point 4 under “Important”, near the top: https://www.steinberg.net/en/support/knowledgebase_new/show_details/kb_show/steinberg-product-compatibility-info-regarding-microsoft-windows-8/kb_back/2020.html

On the contrary, there is usually plenty running in the background - Windows services, etc. A lot of these you can probably do without. What do you have? Can you attach that screenshot you mentioned?

Are your M-Audio drivers specifically Windows 8?

Is it Windows 8 or 8.1? There is a very recent post where Steinberg are recommending that you don’t upgrade for now, as testing is still ongoing. http://www.steinberg.net/forums/viewtopic.php?f=181&t=49037#p298736

One more thought: there is power-saving stuff in BIOS which may be better turned off: C-STEP, etc (terminology varies)

OK I’m a little freaked out now because disabling the wifi adapter appears to have stopped it happening. I just don’t understand that, (though I am grateful for the brilliant advice! thank you) - I’ve never had that before in all the PC builds, Windows Versions and Versions of Cubase either -

Do you happen to know what the issue with wifi is? (and THANK you again)

WiFi has so much information flowing through them these days that they can put a strain on the processor. I believe they have a high priority for resources. Beyond that, I can’t really speak intelligently.
J.L.

Hi All

It always annoys me when I look something up on a forum and don’t find a final post containing an answer so I thought I would close this one down. I’ve solved the problem!

I simply disabled my PCIExpress wifi adapter and replaced it with a USB adapter instead. I can now maintain my wifi connection whilst using Cubase (and as it turned out, anything else with an audio driver!) without the pops and clicks.

This also means my Toontracks software doesn’t have a meltdown when its opened up as a vst with no connection present.

thanks to all of you who took the time to read and respond to this post.

I have to add here, disabling my wifi adapter fixed this issue.
Totally weird, but it worked.
Thank you.

I’ll offer my fix here too since it is slightly different to the rest and started after I did a cubase upgrade from 7 to 9.5.10 and windows 7 pro 64 update to fully patched OS.

I was working fine after this with the on board sound card as long as the ASIO Guard was off, though latency was bad, I didnt get the pops.

I finally got round to adding my Mackie Blackbird firewire interface back in, and sure enough the pops and cracks started as soon as I did on playback and record.

tried everything from disabling network cards, to removing all usb stuff and pretty much everything I could find while searching this forum the last two weeks.

the solution came to me last night and it worked. my problem was a combination of three things:

  1. the ASIO guard being enabled was my main issue, for some reason my Mackie doesnt like it being disabled it peaks out the real-time in idle.
    in the end I had to disable it and then hunt for a fix while in that state. which led me eventually to…
  2. the IEEE 1394 legacy drivers need to be installed instead of Texas instr. driver for firewire, again a known fix but Windows had auto-upgraded when I ran the patches, I guess. Also with the ASIO guard enabled just installing the legacy drivers made no differnce, but when the ASIO Guard was disabled the Mackie was spitting at me.
    and finally…
  3. Tweaking the Mackie buffer to 512 set in low latency mode and that finally calmed it down whe ASIO Guard was disabled and when the legacy drivers were installed for firewire as well, the pops and cracks stopped. phew.

once I did all those things together I got rid of the pops and cracks, if I missed any single one of them out, the pops come back or the real-time mode goes into tilt in idle. maybe a quirk of the Mackie not liking ASIO Guard disabled but that threw me off the main issue, which I am pretty sure was the ASIO Guard, but in my case I needed additional things tweaked to resolve it.

hope this helps anyone looking for a solution. sometimes a combo of them works. only 2 weeks to figure that out!