Fixing automatic system spacing

Any idea why I’m ending up with this spacing in the part?

Of course I can manually adjust, but I have a feeling it’s my settings.

For this part, inter-system gap is set to 10 spaces, and minimum gap with content is set to 6 spaces. Automatic justify is set to 90% fill-to-frame.

I’ve tried tweaking these numbers, but I can’t seem to get what I want. I want to do this the right way if possible.

The problem seems to come from the space needed above rehearsal marks. Can’t you lower the minimum space above them to a smaller length? That would be in Engraving options > Rehearsal marks…

I doubt it’s the rehearsal marks. Dan, can you attach the project here? If you’re not comfortable posting it, you can email it to me at d dot spreadbury at steinberg dot de. Include a link to this thread so I know what I’m supposed to do with it (I get a lot of email and I can end up not remembering what specific problem a file is in connection with).

File here:
Christ the Lord is Risen Today.zip (601 KB)
Thanks!

PS: I should add, I checked Engraving --> Rehearsal Marks, and there is no option to change the amount of space ABOVE the rehearsal mark, only its distance from the staff below it.

Pretty much the same here. A lot of the times when coda-workarounds are involved, but also with rehearsal marks.

kjonsson, is that Coda glyph in Bravura or Bravura Text? You should get better results with Bravura Text (if you’re not already using it).

Dan, win that in mind, it might be worth just double checking what font your rehearsal marks are using, and if there’s any weird padding with the font itself. This is a guess on my part…

pianoleo, I checked on that. Minion Pro is the font, nothing strange there. And doesn’t padding just refer to the distance from the mark to the enclosure? That’s the only padding setting I could find.

As I said, it was a guess, and evidently a poor one - sorry Dan!

The problem is that you’ve set the ‘Minimum inter-system gap with content’ option on the Vertical Spacing page of Layout Options to 6 spaces, in error I think: this means that Dorico is trying to add 6 spaces between any items that protrude from the top or bottom of each system. This is set to 2 spaces by default, which is more sensible. If you want to influence the amount of space between systems, use ‘Inter-system gap’ in the section above instead.

Thanks, I hadn’t thought about that. I’ve been so used to manual adjustments in finale that I’m still getting the hang of some of these automatic features.

Thank you Dan and Daniel for the question and for the answer. This helps me, too!

**Leigh

As a postscript, if it’s helpful to anyone else… I ended up using 2 7/8 spacing for inter-system gaps with content. It gave the rehearsal marks a little extra room for visibility. The part now looks great, with no manual staff spacing needed.

Aaaaaand “Save as Default” (or it could be aptly named “Save for Posterity”). Thanks Daniel. Three cheers for automatic layout spacing!

Hm… it’s in Helsinki Std… Not good? :blush:

Edit:
Ah! Much better with Bravura text, thank you Leo!
(If anyone else needs it - here’s the link where you can copy the symbols you need.
http://w3c.github.io/smufl/gitbook/tables/repeats.html )

kjonsson, I whipped up a quick comparison for you.
I’ve added borders, which show quite how much space there is built into each font. By the looks of things you could get away with Helsinki Text. On my Mac the shortcut for a Coda glyph is Shift+Alt+O (as opposed to Shift+Alt+5 in regular Helsinki Std).

@Dan - could you post the revised/solved version? It would be interesting to see it, if it’s not too much trouble.

Thanks in advance.

Sure, attached. The orchestration isn’t finished, but you can see the part spacing worked out quite nicely. I literally nudged only one system in one part (a trombone, I think)!
Christ the Lord is Risen Today.zip (602 KB)

Aha…! Strange, it seemed as if spacing fell better into place when I changed to Bravura Text, but it certainly doesn’t look as if there should be much difference from Helsinki std.

I’m still puzzled by spacing issues that seems to occur when using repeat endings. Especially in combination with chords and/or rehearsal marks, it tends to make more space than needed between systems.

kjonsson, it’s Helsinki Std that is pushing the stave down in the example I posted. Look at how much less padding there is with Helsinki Text and Bravura Text - if I removed the first example the stave would be 3mm higher (or whatever the gap is between the bottom borders and the stave below.

Right - gotcha! I was only focusing on the upward spacing, probably time to go to bed…!

So, it seems Helsinki Text Std would be the best choice then…? Or am I missing something?

Thank you for all the help!