Fixing live audio to a tempo grid

Hi, I’ve imported a load of stems that were recorded freely without click. I would like to straighten them out to a fixed tempo, in order to squeeze all life and groove out of the performance :wink:
Analysing the drum track has given me a tempo grid, and I have then followed instructions(obsolete?) I found on earlier posts, to re-export the audio to the pool and then turn on musical mode. Unfortunately my re-exported stems all show a tempo of 120.28 in the pool, and act accordingly. If they are to have a defined tempo, it would be around 93, but actually it is variable?!. I’ve tried setting the tracks to linear timebase before bouncing with no success.
I’m totally confused now. Surely by now there is a more straightforward way to do this?

Many thanks for any help here

Now if the tempogrid is correct, simply apply "set definiton from tempotrack (or something like that) to all files, then straighten the variable tempotrack-events.

Hi Sven

Thanks for your answer. I realise that this is the necessary step that I have missed, but I think something else has gone wrong along the way. Having applied this setting, once I delete all the tempo variations and leave a steady tempo go 93, the audio stems all slow down far too much, as if they were set originally at 120.28. Was the step of rebouncing to audio pool still necessary, or was that from an old version of Cubase? Should I simply be able, after having defined the tempo map from the audio, then be able to ‘set definition from tempo track’ and delete the tempo variations on the tempo track?


There is no need to bounce anything.

Without that step it sounds like you’re doing it right.

If the audio is too slow, then the tempogrid analysis was probably not correct. Automatic tempo detection is - depending on the file - not always working seamless in Cubase. But basically yes - if the tempo map is correct, deleting the tempo variations should be all it takes - no need to bounce anything

Ok I think adding the step of rebouncing is probably what messed it up, as the tempo detection was fine when checked with metronome. I’ll try it again with a clean project. Thanks for the replies chaps.