Fixing q Signpost Errors from XML Import

This is my first post. I’m creating backing tracks for personal use from my sheet music collection and I frequently encounter “q errors” during the music XML import process. It has been said to fix these before importing, but I haven’t find a perfect OMR program to generate pristine XML or to correct XML errors (I currently use soundslice.com).

In this example, the repeat bar line near the end of bar 12 wreaks havoc on several bars (12, 13, 14, 15, 29).

I could ignore this, but bar 15 has a hiccup during playback. It is as if there is an extra silent eighth note at the end. How can I fix this? How would I determine the problem without hearing the hiccup?
Handel Allemande.dorico (895.7 KB)
Handel-Allemande-pdf.xml (199.5 KB)

Hi @mbwolk and welcome to the Forum. As you can see from this guidelines is always better to post a Dorico Project that contains an example of the issue, with a detailed description. In your post you speak also about bar 29, that is not visible in your screenshot. In this case maybe you can share also the original xml for someone to experiment.

I suggest that the q is not an “error”, it means quarter note value. And those signposts are not “errors” but are hidden meter changes, that Dorico writes in the process of translating/visualize the original xml.

You can find many preferences for XML import (in Preferences/MusicXML Import) that can be deactivated to let Dorico interpret the xml translation using his own algorithms instead of trying to reproduce the original (with the eventual “mistakes” contained in it). (Deactivating most of this preferences brings often better results.)

Christian,
Thanks for your helpful comments. I have edited the initial post to include the uploaded file. Let me know what you find.

Hi @mbwolk

to correct the file:

  • select all

  • filter for time signatures and press delete

  • delete the repetition bar line and the barline just before the X signpost that remains

  • click on first note and create a 4/4 (or a C) meter with an eight note pick-up (half beat) (from the panel)

  • Select the first note of the three instruments at the point where she hiccup occurs, and choose menu edit/select to end of flow (*)

  • activate insert mode with global scope (the world icon should be visible), (long press the icon to choose between the scopes), and press alt+left arrow once (with rhythm grid set to eight note) (*)

  • click on the last eight in bar 11, and choose the start repetition barline (Dorico intelligently numbers the bars), and in the same way put the end repetition barline where desired at the end.

  • delete the exceeding last bar with the system track

So everything should be the way you need. :slight_smile:
Probably the xml was inaccurate and weird. (Can you share the xml for further experimenting?)

I attach the corrected Dorico file:

Handel Allemande-CORRECTED.dorico (895.3 KB)

(*)

2 Likes

Excellent. Thanks so much. I have been looking for a way to “see” the errors and had not thought to check the Key Editor. I will work through your steps later this evening.

I have also uploaded the original Music XML file to the original post. My process flow is currently PDF > Soundslice.com > XML > Dorico. The XMLs frequently have many glitches like the one in this example and I have been unable to deal with them. For what I am doing, I’m not sure that there is a way around it until Music OMR technology improves.