Flaky behavior from Retrospective Record in C12

Working out parts, I will sometimes jam along with sections and use Retrospective Record to capture anything interesting. Last evening, numereous times I wanted to capture what I had just played. When I hit the RR button near the transport, nothing apeared in the track. Nadda… and the button then “grayed out” meaning the buffer was (now) empty. This happened several times during the session on different tracks… Closed the session and Cubase. Started Cubase. Opened a clean template. Happened again with the clean session… It appears to be random. But I was able to reproduce the behaviour during the first session…

Windows 10 Pro 21H2. i7-8700k. 32gb RAM. All SSD drives. RME Babyface Pro FS. Cubase 12.0.10

I used Retrospective Record a couple of times last night in Cubase 12.0.10 without incident. I’m not in Cubase at the moment, but I’m not sure what you mean by the RR button near the transport. The way I was using RR, I played a long with the track, decided I wanted to use RR, then I went to the track inspector for the track, pulled down the menu item for RR, and chose something like insert part linearly (I don’t recall the exact wording), and that put the part I’d played in the track. I should probably also note that the track in question was selected as the active track, and the record button was enabled (I just was not recording while playing the part).

Thanks rickpaul for the response… The RR button is to the far right of the transport. I also use RR from the track inspector as you discribed. When this happened, the RR in track inspector was also “grayed out”

Okay, I see what you are talking about now on the button:


Darn obscure-looking buttons. :slight_smile:
Anyway, I just tried it now (in 12.0.10 Pro). I actually didn’t have the track armed for recording. When I first clicked on the button (I was only selected on a lane of the track, rather than the track header itself), it warned me to arm a track for recording or select a track. (Perhaps I was actually selected on a marker track or something other than an active instrument track at that point and selecting a lane of the track in question didn’t change the selection?) But once I selected the track header for the track in question, the notes I’d played were put into the track, albeit overlaying the top lane, rather than in a new lane. (I’d noticed a similar thing yesterday when using retrospective recording in that the notes went over an existing lane, though they separated out once I did a clean up lanes command – the new recording ended up in the first lane of the track rather than the previously empty lane.)

After I did that, I looked at the RR pulldown in the track inspector, and it was grayed out, but the button on the transport was not. So I did another similar exercise, playing over a part, and this time I could put the RR info in the track from the inspector, but the inspector version gets grayed out right after doing that, whereas the transport button does no (and still seems to work for me, I think)

Even more interestingly, if I used the track inspector function to empty the RR buffer (while it is still enabled), it gets grayed out, but the transport RR button does not and still works for inserting MIDI data (I did not check to see if it was what I played – I was really just playing garbage then undoing after the inserting to test this).

I guess the bottom line in my case (and I’m on Windows 10, FWIW), is the retrospective recording seems to work okay for inserting data, but the behavior of the button versus the pulldown (which is all I’ve ever used previously) versus the empty buffer command is at least inconsistent. One key, though, is that the track you’ve got selected is not frozen or deactivated, and is an instrument track (at least in my case – I am not using multiple outputs from VST instruments nor any external synths), and not a just a lane in such a track (perhaps with another non-MIDI track being the active track). But, when I tried inserting the recording in that latter case, it gave me an explicit warning.

Hi Rick… Ive been using Cubase since version 4. I was previously a Logic for Windows user. When Apple bought Emagic, I didn’t want to go down the Mac/money rabit hole, so stuck with PC. Still used Logic for PC V5.5.1 for a few years after. One of the main reasons I went with Logic in the first place was for their RR - “Capture Last Take As Record”… Cubase was by far the best option for PC.

Anywho… I do have lots of experience using this feature. That said: The behavior you have kindly detailed above is/seems appropriate.

My track was armed. No multi-outs etc. It simply failed to place any data. This happened several times during my session last night.

We’ll see how it goes

Thanks again for your input