Flaky VST instrument playback

I’m using Cubase LE4 on a Windows XP Pro machine, and with a TC Electronic Konnekt 6 interface. The audio side of things seems to be working okay – I’ve recorded a number of tracks with electric guitars and WAV drum loops etc. I’ve run some latency checking software, and that reports everything working okay.

I’m starting to record some midi tracks using a guitar synth. I’ve bought a Hammond organ VST instrument (GSI VB3) and I’m having some problems with it. Last night I recorded a new song with only a single ‘organ’ track – no drums or anything else. When I tried to play back the midi track, I couldn’t hear any audio. VB3 has a number of presets, so I selected another one of those, and it played. However, I had the song on ‘loop’ mode, and when it started to play the second time, the audio went dead again. If I selected another preset, it played until the song went back to the beginning of the loop. Any presets I’d used weren’t audible, but when I selected a new one, it played for the first time through the song.

I tried changing the Instrument to the Halion included with Cubase, but those sounds didn’t play. When I reloaded VB3 it played for the first time through the song.

I’ve tried restarting the computer and the software, but something is still flaky. I looked at the VST monitor in Cubase, and it doesn’t seem to be maxed-out. There is a red circular LED flashing next to the RW indicators at the top of the VB3 interface (I think it might be a Cubase indicator) and when I hover the mouse pointer over it, it says something about events are logged.

I’m not really sure what’s causing this problem – PC, or the VB3 software. However, it’s seems a bit dodgy with the Halion software, too.

I hope someone can help!


I am not an LE user but I will try to help.
The red LED next to the RW buttons is the “events received” indicator. If it is lighting up then the VSTi is getting the MIDI information. Look at the channel meter during the drop outs to see if the problem is between the VSTi and the Cubase channel or between the channel and the sound card. Make sure you have any updates applied to Cubase, the ASiO driver and make sure the ASIO driver for the audio card is selected in the VST connections (Cubase defaults to a generic driver).
Other than this I don’t know what else to suggest.

Hi JasLan

Thanks for your reply.

I’m new to midi and Cubase, so I’m not really sure what’s going on. I may need to do more testing. However, I’ve just played the test project again, and experienced the same problem – I hear the track the first time I play it using a ‘new’ preset, but the second time the track plays with that same preset, there’s no audio output.

I’ve checked versions, and I’m running the latest version (including hotfix) of Cubase, and also the TC interface drivers and firmware are current. It’s using the TC Near ASIO driver.

When it’s playing, the vertical bar meter on the left side of the transport panel (ASIO time usage) is showing activity. When the audio is playing the Audio activity meters show activity, but not when the sound disappears.

I don’t really know enough for any of the settings to jump out at me. I’ve had a look to see if there’s automation on the track (there isn’t) – I was wondering if there was some sort of ‘midi mute’ being set after the notes had played during the first run-through with a preset.


I have a bit more information.

I think there actually is some sort of ‘code’ embedded in the track. The track has a vertical line at somewhere around Bar 4, and one at around Bar 19 (they’re not on a regular beat). I’d set the left hand locator to Bar18, and was looping from there, and hadn’t noticed the one at Bar19 because I’d assumed it was an indicator of the left locator.

However, when I took the left and right locators off, I ran the track right the way through, and noticed the muting is happening when these vertical bars are reached. If I run from the beginning, it mutes at Bar 4, then if I select another preset, that one will play until Bar 19 is reached.

However, I have no idea what these bars are, or how to get rid of them. It looks almost like the track is split into segments, but it’s not – if I click on the track, the whole of it is selected, not just a section to the side of the vertical line.

I hope all that makes sense!


It could have some MIDI controller data in there that is muting the notes. Look in the manual about MIDI controller editing.
It could also be Automation data the is silencing the output of the track. Right click on the track in the track list and select “show used automation” to see if there is any.

Thanks for that, Jaslan.

I don’t think there’s any automation – I checked that before using ‘Show all used automation’, and there was nothing to display.

Having identified that there probably is something in the midi data, I suppose it could be down to my guitar to midi controller sending out some funny control codes every so often. I’ll read up on the midi controller editing, as you suggest, and hopefully that will let me see what’s been inserted into the track.

Thanks again.


Open the List Editor and see if there’s anything in the first line that may be causing the issue. In Prefs, go to the MIDI Filter section and make sure only sysex is checked.

Thanks for that, MashedMitten.

I’d found a workaround (from Midi note editor screen, select ‘Midi’ then ‘Functions’, then ‘Delete Continuous Controllers’). That seemed to have sorted the problem. I didn’t save the changes, as I was planning on trying to find out what those ‘Continuous Controllers’ actually were.

The Sysex setting was as you suggested. However, the List Editor showed the following group of events at both sections in the track.

Controller CC 100 (RPN LSB) 0
Controller CC 101 (RPN MSB) 0
Controller CC 6 (DataEnt MSB 12
Controller CC 100 (RPN LSB) 127
Controller CC 101 (RPN MSB) 127
Controller CC 7 (Main Volume) 0
Controller CC 10 (Pan) 64

I’m not exactly sure what the different codes are, but the CC 7 looks like it was switching off the sound.

Do you have any idea what might have caused these parameters to have been set? I’m trying to remember if I made any changes while I was recording. I may have changed a preset on the VSTi, but I don’t recall having done so. I certainly didn’t change volume levels.


CC7=0 will basically stop the sound by turning the volume down to zero.