Flashing Peak Lights

I have connected my “new” UR22C to my PC. The USB led doesn’t blink. Both peak leds are continously flashing.
I have reinstalled the drivers several times, but the problem remains.
Does anyone know where I am doing something wrong?

I have the same issue. It’s not mentioned in the manual. Can’t find any troubleshooting instructions. Steinberg, high time to respond to this issue!

Today, after trying in vain every possible other solution, I went back to the store with my laptop and UR22C unit and tested another one in the store without problems. So it turned out to be a manufacturing defect. So happy now that everything is working fine, also in Studio One, my favorite DAW.

I had the same problems. Flashed FW 1.01 from the Steinberg side with a Mac solved the problem. I wasnt able to patch it with the Windows version, it couldnt find the device for some reason.


On Windows 10 loading new firmware solved the problem.

I have the same issue since yesterday. Out of the blue my interface started flashing the peak lights. I updated the firmware and reinstalled drivers. But no succes. I even try to connect the device on antother laptop but with the same result: flashing peak lights.

What can I do? I am not very technical and just want to record some songs.

Thanks for your help.

Fawzia