focusrite mix software driving me nuts

Please please does somebody out there know how to use the mind boggling mix software that comes with the Saffire pro 24 DSP.?
all I’m trying to do is get a mic signal from my SPL track one through the pro 24 via line input 3 onto a track in C7 using the zero latency facility plus a bit of reverb…just can not make it happen !!! keep going through the manual but it just aint clear how to do it…at least not to me and there is no mention of it on the Focusrite site that I can see. just seeing red mist at the moment !!!
if I engage the monitor button on the track I can hear the signal but then I’ve got latency, how the heck do I get it there otherwise?

fingers crossed someone can help…Kevin

Select correct ASIO driver then set up VST Connections. Sounds like you have Direct X ASIO selected now.

Hi,I have the correct ASIO driver selected and my VST connections are set up…I just can’t figure out this routing thing for zero latency with some reverb and getting the signal to a Cubase track to record dry, I’ve always had probs with routing in the box because it never seems intuitive…not to me anyway and the focusrite software mix just has me up against a wall, I know I’m missing something just can’t figure out what,
at the moment I’m monitoring through Cubase using the monitor button and reverb from plugin so got a little bit of latency, would really love to be able to use the pro 24 to it’s full ability…thanks for trying to help, Kevin


I have Liquid Saffire 56 so my Mixcontrol is a little bit different but routing logic is the same. When using low latency monitoring make sure that Mix 1(L) and Mix 1 ® are routed to your Monitor Outputs. Fastest way is to use Routing preset called “low latency tracking”. Then select Anlg In X (the input your SPL is connected) to first channel in Mixcontrol. Raise the fader and you should hear the signal in your monitors. Make sure line level input is selected if you´re using line out from SPL and check that Mix 1 output is not muted, fader is up and it is routed to Mon1&2. DAW 1 & 2 input is your return channel from Cubase so everything playing in Cubase is coming thru that. So don´t use Cubase input monitoring because you will hear the signal twice (the anlg input and DAW 1 & 2). I´m not sure about the reverb thing because I don´t have DSP but is seem that there´s Reverb send tab on the top right corner and reverb return channel also… so that will do it.

I´m tracking using buffer size 64 so latency hasn´t been problem for me. I´m using FX tracks with plug-ins if I need reverb or delay during tracking. MixControl is pretty good when you get your mind around it. Basicly just select your inputs to faders -> balance them with DAW 1 & 2 (existing tracks in your Cubase session) and monitor thru Mix Ouput.

Hope this helps!

  • Tupi -

Hi again!

I think the videos on the right might be helpful!

  • Tupi -

Hi tupi and thanks for looking in but I’m gonna give up on this and any other interface that comes with it’s own software window, decided to get an analogue mixer and a simple audio card…4 in 4 out plus midi with absolutely no separate mixer window or whatever, thanks again and best to you…Kevin

Have you set up the routing for the Saffire?

The output faders [on the far right] of each tab send the signal to whatever speakers you select in the small rectangles above the fader.
The tabs on the mixer app are for direct monitoring. So the sound you are monitoring does not go through Cubase at all.
On the Pro24 we use the first tab for our main monitors. So on this tab we can listen to any input through the studio monitors without running Cubase at all.

On the second tab we have a headphone mix, the third is routed to the subwoofer, and the fourth to a centre mono speaker.

In Cubase you create a track, select input three in the inspector and record. :sunglasses:

Hi, thanks for looking in, I actually got a reply from Focusrite and the problem is solved…thankfully, however, the reverb on the pro 24 DSP is unusable…like singing in an oil drum, so it’s gotta go…I’ll get there eventually…Kevin

I have the Focusrite Saffire Pro 14 and was getting confused with the combination of its mixer and Cubase 7. This lead me to this thread and after reading I set about it again and my problems were solved. So thanks all.

I was getting a delay, the same kind that the “Turn Global Off” option in older versions of cubase would solve. Also, each time I did anything to the Saffire mixer Cubases metronome would fall silent.

Both these issues were sorted by selecting “Daw Tracking” in the Routing Preset menu, and then selecting Asio Saffire in the Device Set within Cubase.


Saffire Mix Contol > Daw Tracking
Device Set up Asio Saffire

I don’t sound like I’m playing in an empty arena now.

I got this from Focusrite which solved the problem I was having, which was low latency monitoring using the onboard reverb…really don’t know why the tutorials are not as concise as this…

First set up a track in Cubase to record onto.

Then, ensure your MixControl is on the Input FX, not VRM, setting.

Reverb Returns is a fader that represents the amount of reverb signal to be included in the Mix, as defined per channel, by the Reverb Send. Don’t worry, you will know what I mean in a moment.

At the very top of MixControl, you will see a tab called Reverb Send. Click it and you will see the faders move around to represent what volumes things are in this area, and thus to represent what audio sources in your Mix will have reverb on them. You will also see controls for the reverb in general, such as room size etc.

The trick is to ensure that reverb is only applied to what you want it to be applied to. Assuming you are using Input 1, ensure the fader called Anlg In 1 is turned up, and everything else is turned down. Also, ensure that Anlg 1’s pan fader (at the very top, right underneath where it actually says ‘Anlg In 1’ there is a horizontal fader with ‘L’ on one side and ‘R’ on the other) is in the middle, on ‘C’.

Then go back to Mix 1, and turn up the Reverb Returns fader. You should now start to hear reverb on your single input, but not anything else. Make sure that Anlg In 1 in Mix 1 is centrally panned too.

If anything goes wrong, or things look different to what I have described, then go to File > Restore Factory Defaults and then go through the process again.

I have attached screenshots of both Mix 1 and Reverb Send to show you what I mean.

That should cover it. Please let me know if I can be of any further assistance.

Best regards,

Actually, I had the Saffire pro 40 and I thought the mix console was great, it didn’t have reverb however but the routing was fantastic.

Yeah I’m sure it is, I just don’t/can’t understand it…

Hi Shadowfax,

Thanks for your thread and feedback.

According to your latest reply in your support case, it looks like you can understand Saffire Mix Control in the meantime.

Please don’t hesitate to contact our support again, should you need any further assistance.

With best regards,

Marcel // Focusrite Novation Support

Hi, your support was great, I thank you for that but I have moved on to a Yamaha N8 which I find much easier to work with…Kevin

Hey Marcel,

I just bought a new Focusrite Scarlett 8i6 which also includes the MixControl software. After tons of youtubing I finally figured it out. It really is quite complicated at first, Kevin. :wink:

So my question for you is: what will be the focus of new development with your DSP software/latency performance? After all, you don’t need DAWbench to tell you that Focusrite Scarlett’s dont get the best latency around. I hate to be negative as Focusrite interfaces have alot of potential but the bad latency almost makes it unusable. So is there any work going toward improved latency performance or a DSP monitoring software with FX?