Force stem up with multiple voices don't work

If you have multiple voices and tied durations the force stem up command does not work on the second note, In the attached example the “C on four”! Am I doing something wrong or is it a bug?
Force stem up do not work.png

I tried to replicate your example and I get the same result. The first 8th obeys to the force stem up option but not the tied crotchet on the fourth beat. A workaround is to use slurs instead of ties, which is not a problem if you do not need the player mode. Anyway, it was worth noting it, maybe we will get an explanation about this behaviour.

I’m aware of that workaround with slurs, but its not a proper behaviour of Dorico.

I think it’s a known bug, and it should change all the stems of tied notes in write mode. What you can try is to switch to engrave mode, where you can select only the C on the fourth beat, and invoke the force stem command.

Is this still a bug (meaning it will be fixed) or is using Engrave the correct way to do this?

Yes, for the time being you must still switch to Engrave mode to do this.