Frame won't move

I’m trying to adjust the frames in a layout. The music frame is very difficult to select by clicking: it won’t highlight no matter how accurate I try. I can only select it with the arrow keys.
Once selected, I can’t resize it. It just won’t drag. Is there a Lock somewhere? I want to move it INTO the page, so within the constraints of the margin.
And sometimes, a bar will disappear from the music (even though I’ve turned off Write-on-double-click and I’m not in Write mode so I don’t accidentally click on the bar’s delete button).

The text frames behave similarly, though I can edit their contents.

I’ve quit and relaunched, just in case it was temporary madness. But it’s still happening.

Chances are that it’s already as wide as the page margins will allow, and as such you won’t be able to drag it left or right.

Drag a corner to shrink the frame (or type numbers into the properties panel at the bottom of Engrave Mode), and THEN drag it.

I’m trying to shrink it, not move it.

Hmm. The top middle anchor point won’t respond, but all others do.

It may be locked. Click the relevant padlock symbol on the left panel to remove that constraint, or fiddle with the “top” value in the bottom panel.

I can select and move the frame in other documents when the padlocks are on. It’s just this one where it won’t select and won’t move.

If the problem’s specific to this one project, we probably need to see the project file, or at least a screenshot of the problem page, in Engrave mode, with Frames turned on and the left and bottom panels open.

Here’s a screenshot.

I cannot shrink the top downwards using the middle handle. I cannot select the frame with the mouse. I can shrink the frame with any other handle.
I can’t see any difference between this and other documents.

I can take a look if you email me the file, Ben. (In the email, remind me what it is I’m supposed to be looking at and why, otherwise I’ll forget: I get too much email to keep everything straight in my head.)

This definitely looks like a bug:

If I create a brand new document, I can resize the first music frame easily. As soon as the first system fills the complete width of the frame, the frame cannot be selected with the pointer, and will not re-size with the pointer. (I can select it with the arrow keys, but I cannot re-size it with Alt-Ctrl arrows.) I can re-size it using the properties panel below.

What is more, clicking just below the top middle of the music frame can cause a bar to be deleted! This is within Engrave mode, not Write mode. (I’m not accidentally double-clicking to get into Write mode and then hitting the delete bar icon.)

I have deleted the Dorico preferences, and still get the same behaviour (in existing documents). I see it in every document, and on two computers. I’m on Mac OS 10.13.5.
It’s possible some other factor is at play: the Example Projects work normally, so perhaps something in my document’s settings (and now my default) is bad.

After trashing the Dorico settings, new documents behave correctly, but existing ones still contain the problem.

If you post a file that displays the problem here, then we can all take a look and try to help. By the sounds of things you’ve probably inadvertently changed a default…

Weirdly, Daniel said the file worked for him fine. But here’s a sample.

I’d just got all my settings exactly I wanted them, so it will be really annoying to throw them away.
RogueFile.dorico.zip (456 KB)

Ah: Restoring the Layout Options to Factory Settings fixes it for each document. Must be some sort of corrupt settings or unparsable XML.

I’ve just played with your file, and with a couple of new files.

I think the System Track is wreaking havoc, basically. It’s hidden in Engrave mode, but it’s still responding to mouse clicks despite the fact it’s invisible. In your document and in other new projects it is indeed impossible to grab the top of the frame if (in Write mode) System Track is turned on.

My workarounds are:
Turn off System Track before heading into Engrave mode

OR

Select the left or right border of the frame with the mouse, and then Tab to the top left corner. From there it should be possible to either drag down or use Alt+arrows or Cmd/Ctrl+Alt+arrows.

I think this would indeed explain why I get different results to Ben: we have already fixed the problem whereby the system track’s click areas are still active in Engrave mode. This will certainly be OK in the forthcoming minor update. Until then, as Leo says, switching off the system track (Alt+T) before going into Engrave mode is the right strategy.