French keyboard, key shortcuts and accents


I’ve searched the forum, but without finding a specific answer to my problem. On my keyboard layout, to do accents, I have to first press the accent key to store the accent (`) in memory, then press the letter to get à, è, ò, ù and so on.

The problem is that for Dorico, I cannot seem to be able to map key commands to those keys, since the first time I press it, nothing happens, the software doesn’t receive a “letter” until I press a second key. This is annoying since it’s all the keys that would normally have the articulations.

Technically I guess the problem is that Dorico is having a “software” access to the keystroke, waiting for the driver to send it the actual character, while it should in these cases have “hardware” access and react to the keypress itself. I had that same issue in Sibelius, it worked very well while Daniel was there (lol), and then with some subsequent update it broke for a long while, and eventually they fixed it in some update.

I tried setting the keyboard language to french but it didn’t help. I am on Win 10.


Have a look at this thread

Thanks, I saw that, but it was for Mac and about a year old, I was wondering if something had changed since, or if the situation was different on PC.

Dear georgesdimitrov,
I use a french keyboard, and the accented letters are not “dead keys”. Yet, I have two of those keys in my keyboard, but I do not use them in Dorico (except when writing text). That is why I do not really understand your problem. Your keys must be mapped differently than mine, or your needs must be different. I would like to understand what is it you are trying to do and that you can not.

It depends on the keyboard layout. I use French (Canada). In my case it’s the three keys here:

There aren’t THAT many keys on a keyboard, so wasting three of them is not ideal.

“[” in particular is by default for accent articulation. I can actually get my keyboard to type a bracket “[” by pressing the right Alt+that key, but for some reason, Dorico is not registering it as a [ and not placing an accent on a note.

In the french keyboard, your [ key is a double “dead” key : it gives ^ accent and ¨ when shifted.
I use a mac, and sometimes the Unicode keyboard, and also russian and Czech. I can switch keyboards with cmd-space and I know which keyboard I’m using thanks to the flag on the top right corner of my screen. I know it’s not very practical, but if your keyboards behaves well for music in canadian, keep the other languages layouts only for inputing text.