French language and English keyboard shortcuts

Hi,

I am just starting to look at Dorico workflow. Looks like excellent work!

One minor bug? I see that you can select your interface language (in Preferences > General) and your keyboard language (Preferences > Key Commands) separately. For my part, I would like to have a French interface language with English keyboard, since Canadian French keyboard is QWERTY and much closer to English keyboard than French.

However, while in Preferences > Key Commands I can choose French/German/Italian/etc. keyboard, there is no English option. There is only a «Default» option can is English when interface is in English… and France French keyboard when in French.

Shouldn’t it have an «English» option to choose there?

I agree, it should, but doesn’t at the moment. Have logged this internally, hopefully will be able to address that in an upcoming patch release.

Hi,

I see the posting about the french canadian keyboard as been written by 2016. It is not looked yet. Can I get some help about setting out the shortkeys matching with this keyboard?

Thank you,

1 Like

New to Dorico, Just reading this post. Has it been figured ? Interesting that the articulations are the 4 keys to the left of the Enter key, but for a french canadian keyboard, it becomes :
^çèà ¨ÇÈÀ = kind of unusable
And is it a bug ? I assigned ç to staccato, but only Ç does the staccato… not the ç (Capital Ç)

Thanks

We don’t provide a set of default key commands for the French Canadian keyboard layout, I’m afraid. My recommendation would be to set up shortcuts that work for your purposes, whatever they may be. Some keys on international keyboards are dead keys (adding accents or diacritics to a letter produced by another key) or are handled inconsistently by the Qt application framework that Dorico is built upon.

1 Like


Now that we are at version 4, there is an English keyboard option for the French version, as you can see in the attached image: Raccourcis clavier (Keyboard shortcuts) > Langue du clavier (Keyboard language?).

Then I change the keyboard encoding to EN-CA, so now I can use all given shortcuts. A quite good workaround.