Fresh Install but no Loops and Samples

I have downloaded and run the install program but the Loops & Samples section is empty, so is VST Instruments. Should there be something in these sections? I have seen videos that indicate there should be.

This is installed on Windows 10.

Hi and welcome,

Make sure you have installed from the Full Installer, please.

I am pretty sure it was the Full Installer - that’s what the download assistant said. The file it downloaded was called Cubase_LE_AI_Elements_10.0.15_Installer_win.zip

I extracted that to a folder in c:\temp and then ran Cubase_LE_AI_Elements_10.msi. There is a Setup.exe file but that just starts up then closes down without doing anything.

Hi,

Then I would guess you don’t have all necessary components installed. Like for example Microsoft Redistributable.

If so, why didn’t the installer tell me that? I received no errors during the installation, or when I started Cubase.

So, what do I do now? (uninstall and give up is top of the list at the moment :cry: )

Same issue here…I’m just downloading random sound content and seeing what will work. I wish there was a list.

https://www.steinberg.net/en/support/content_and_accessories/sound_content_downloads.html

Has anyone sorted this yet? I am having exactly the same issue. No loops or samples. Very frustrated, used Logic for years with no issues. Moved to cubase on advice of my lecturer (Film Scoring and composition) and now very frustrated and getting close to giving up and going back to Logic. Anyone sorted this can advise me please.

Hi and welcome,

If you are on Windows and you install Cubase, make sure you:

  • Download the Full Installer.
  • Unpack the ZIP file and install from the unzipped folder.
  • Install from the setup.exe.
  • Install as administrator.

I have 2 versions installed on Windows 10.
Cubase 10 shows me everything in “Loops and Samples”
Cubase 10.5 only shows “EDM Toolbox”
on Mac there´s no problem.

is it really necessary to download the Full Installer?
Why do I have to install as an Admin?

Hi,

If you can see the content in Cubase 10 and you don’t see it in Cubase 10.5, the problem is not in the content then. But maybe Cubase 10.5 reinstallation (with admin rights, to be sure, Cubase has full access to all components and folders it needs) would may fix it.

If not, I would try to delete Cubase 10.5 Preferences folder, especially MediaBay related files.

Cubase Preferences folders are:
Mac: ~/Library/Preferences/Cubase X
Win: %appData% Steinberg/Cubase X_64

1 Like

Thanx again!
Maybe I will try out Cubase 11

1 Like

Hi. Same issue. macOS Big Sur. No loops/samples. Do I have to uninstall and re-install Cubase AI 11?

Hi,

With Cubase 11 the library is not part of Cubase 11 installer. Please download and install the library separately.

1 Like