Frustrations with using bluetooth headphones on mac

I am trying to use bluetooth headphones on an M1 macbook pro, and have had no luck, no matter what combo of settings I use.
I tried using rosetta
I tried the agregatted devices solution you have linked in multiple other answers
I tried changing the sampling frequency (44.1 and 16k are the only options for my bluetooth headphones)
I tried restarting Dorico multiple times
I tried resetting VST
I tried changing the buffer and also setting device attenuation to 0db

Right now I see the selection bar for headphones in dorico (though I didn’t before)
There was one time when I restarted Dorico and selected my headphones, but it would both play an amplified version of the ambient sound around me as well as the contents of my file. That was the only time I got it to work. I couldn’t replicate this after I restarted Dorico again.

I’d appreciate a step by step on what I could try (as opposed to just linking to stuff I have likely seen before, like this: support[dot]apple[dot]com[slash]en-gb[slash]HT202000). I know it might be easier to link to other things, but the use cases in those links are slightly different, and I’d appreciate a step by step of what I could do specifically in Dorico.

I’m using the WH-1000XM3 headphones

Hmmm right now playback through headphones is working, but I’m hearing ambient sound amplified through the headphones as well, unless I lower the volume. This only happens when Dorico is on, when I close it, the headphones stop playing the sound going through the mic.

OK, now I’m not hearing mic input through my headphones in Dorico. I can’t point to anything specific I did that helped. I spent about an hour trying to figure this out before I gave up and just started working on music. To clarify, I’m not using the aggregated input solution. I just have my headphones selected at 16Hz.

Sorry, I can’t help with Mac related problems. However, there have been a number of threads about setting up bluetooth headphones on Macs. I suggest you search the forum.


16 kHz is the sampling rate used for the microphone of the air pods. It’s way too low for any output, which is why you should chose either 44.1 or 48 kHz.

1 Like

If I do the following steps in order, it works reliably on my m1 pro:

  • (restart computer)
  • successfully connect AirPods to the computer
  • start Dorico
  • chose them as output

Dorico really should totally closed before connecting the AirPods (or any Bluetooth device).

1 Like

I’m the one who wrote the FAQ section on BT headsets. If you follow that and still can’t get it to work, I can offer a remote screen sharing session where I could guide you through. In case you want it, send me a private message and we’ll arrange the details.

1 Like

Wow! I really appreciate the prompt help!
Right now when I tested it, it’s working. The headphones are set to 44.1 kHz.
I’ll try the step by step instructions when I encounter this issue again. The FAQ seems much more helpful than the links I saw before when browsing the forums.

1 Like