FX Chain Presets Problem

Hi,

Do you have 100% reproduction, please? If yes, could you describe it in step by step way, please?

I can confirm I’m see the same problem in 10.5

I haven’t been able to narrow it down exactly, but in a brand new fresh project file, everything works.
The problem only seems to be in project files that were created in a previous version of Cubase (and have been resaved in 10.5):

Saving:
Open Channel Settings > Inserts > Save FX Chain Preset > Give it a name > OK

Loading:
Open Channel Settings > Inserts > Load FX Chain Preset > Choose previously created preset > OK > (nothing happens)

Loading also fails in a brand new project if the preset was saved in an older project.

I know bugs happen, but it’s really quite frustrating - it’s a big part of my workflow that’s now crippled, again.
Worryingly, without knowing anything about the development process at Steinberg, it does seems to indicate there are no unit tests and no regression testing for this to have been broken twice now.

If I get some more time I may try and narrow it down further.

This is supposedly fixed, but you never know some cases aren’t actually covered.

So it is not happening when loading FX Chain Presets that have been saved in the Cubase version containing the bug? This won’t work, as it’s the preset being broken.

If it happens on older projects saved in 10.5, were the projects created on the version that contained the bug?
Is it possible to get the FX Chain Preset file and ideally the cpr file, too?

Hi,

In one Cubase version, this bug was highly present. Once you stored the preset in that version, the name of the preset has been corrupted and you cannot load this preset anymore (in any Cubase version). This has been fixed (at least the most obvious case). Since then, the same issue appears time to time to some users even with newer Cubase version and with a new presets. But unfortunately, there is no clear step-by-step reproduction available (with the new preset, made from scratch in the current versions), so its hard (impossible) to catch it.

Martin, Fabio, thanks for the replies

The old projects were created in version 9 or earlier I believe. I’m afraid I’m unsure exactly which version though. It could be as far back as 7.
(essentially, I have some template projects that have been periodically updated over the course of a few years)

I’ve narrowed it down somewhat, though it’s quite peculiar.

In the old projects (re-saved in Cubase 10.5.0), saving FX Chain Presets seems broken only for some tracks. Other tracks can save successfully.
The broken tracks appear to have had the plugins added to the track in the older version of Cubase.


Here’s what I’ve tried, all carried out in Cubase 10.5.0 Build 68 on Windows 10:


Create a new preset in a brand new project.

  • Load it into a brand new project (or the same project) PASS

  • Load it into an old project PASS


    Create a new preset in an old project from a new track

  • Load it into an old project (or the same project) PASS

  • Load it into a brand new project PASS


    Create a new preset in an old project from an existing “tainted” track

  • Load it into an old project (or the same project) FAIL

  • Load it into a brand new project FAIL

If all plugins are removed from a tainted track, followed by adding new plugins, then saving and loading FX Chain Presets seems to start working and the track is no longer tainted.
First party or third party plugins doesn’t seem to make a difference.

I’ve attached 2 problematic FX Chain Presets - created in Cubase 10.5, from “tainted” tracks from a pre-Cubase 10 project.

Fabio, I’ll PM a project file over

Many thanks
FX Chain Presets.zip (3.91 KB)

Thanks for the project, got it and can reproduce it with the tracks you indicated.

This sounds like something that might indeed be ‘heritage’ of a bug… anyhow, it’s already reported.

Thanks again!

No problem, glad you could reproduce the issue. Thanks for reporting.

If you happen to discover whether those tainted tracks are fixable with a patch or not, it would be great to know.
I have quite a lot of projects with that issue! (Often with a couple of hundred tracks). It’d be good to know if I should begin recreating them all, or if some less important projects can simply wait for a patch.

Thanks

For anyone else still having trouble, Fabio kindly pointed out the issue in the XML fxchainpreset files.

After taking a backup of all my fxchainpreset files, I ran the following find and replace on them (with an editor that supports Regular Expressions):

Find:

"(Editor Name.*?)" value=".*?"

Replace:

"$1" value="editor"

That brought them back from the dead :slight_smile: