Garritan JBB3 and Dorico, problems


I’ve managed to make a whitelist, expression maps for some of the mutes that brass uses. Everything worked up to a point. A few questions that maybe someone can help me with.

  1. I’m using Aria Player SVT Multi, it plays back, the playing techniques are there but it plays back only through channel 1 in the Dorico mixer. I can see all the instruments on the corresponding channels in the Dorico mixer, but all the channels form Aria Player goes directly to channel 1 in the Dorico mixer. What am I doing wrong?
  2. How do I change some of the playing techniques? For instance “harmon mute, with the stem out”. For Jazz that’s redundant, harmon mute = no stem so you don’t have to write that out. If I use Open to indicate going from mute to open nothing happens. I must use natural, very strange and not used at all in jazz.
  3. I thought that the expression maps I’ve made would be possible to access when starting a new project, but they’re nowhere to be found. I seems like they’re only in that project where you created them. How do I access them from a new project?
  4. I guess the best way to go about this is to do a bunch of empty project with all the settings right and use them. But sometimes you need to do something new and then i would be helpful to access previously made expression maps.

Besides these problems it works really well.

  1. Aria doesn’t populate itself so you have to set the return channels manually (see attached)
  2. As of 2.0 you can make your own Playing Techniques… and reference them in your Xmaps…
  3. you can select your own (one or more) XMaps on the left and then click on Export Library… In new files you can load this set by clicking Import Library (There MAY be other ways now, but I’m not near Dorico atm… :slight_smile:


1.With help from a friend I managed to set the channels right for playback. So now each instrument has a separate channels and effect return works.
2. Playing techniques sorted out. My edited techniques played back, that is for a while, but all of a sudden Dorico stopped playing back any dynamic or playing technique. No matter how I search in all the settings I can come to think of I can’t figure out to get them to play back. What did I do wrong?


Olfdan, make sure that you still have the right expression maps chosen in the Endpoint Setup dialog (the little cog button in the VST Instruments panel) for your instance(s) of ARIA.

I guess you’ve discovered that the effects from the Aria player returns to Channel 1 in the Dorico mixer. So it’s a good idea leaving channel 1 (output 1/2) in the Aria player empty, otherwise that instrument plays back on the effect return channel in Dorico. (i.e. place the first instrument on channel 2, output 3/4). :slight_smile:

Hi. I hope it’s OK to post a continuation here? Well, I have read the online help and looked at several videos but I am still having no luck trying to hear my JABB3 voices. I have updated the Aria Player to the current vst3 version. I can load all the voices I want into one instance of the Aria player (Note: I am assuming that the voices beyond midi channel 12 will not play due to the limitations of Elements 3, which I currently have, rather than prevent anything AT ALL happening :slight_smile: ).

In Aria all channels go to midi ports 1/2 - that’s the only option anyway. Apart from the flute on channel 1 (I guess I’ll have to look at the effects issue raised above eventually) I can use the Aria keyboard for all the channels in Aria to check the sounds.

In the Endpoint set-up all the channels refer to ‘default’ expression maps. In the Mixer there is 1 audio output, marked Flute. I have left it at one audio o/p, having tried 16 and getting nowhere. All I hear on Playback is a flute voice - that actually doesn’t sound like a part, but a combination of many sequential midi messages all defaulting to the flute voice - monaurally!

If I click on a midi note message in the Play window it doesn’t play back.

I am using a user template for Aria so I have a full big band set up (4 x sax, tpts, trms etc) but the midi channels in the Play window doesn’t necessarily match up to the vst channels in Aria. The channels in the Set-up window were allocated sequentially when i added players and voices. My user template has a slightly different allocation, but mostly it’s the same.

I have created a .dorico file to test this, but it doesn’t work for xml files that i bring into Dorico with a view to working on, then saving as .dorico files either.

Any ideas? Thanks. Please see a couple of attachments.

Last I looked into this the VST3 version of Aria unfortunately isn’t multichannel yet, so you still need to use the VST2 version. Just whitelist ARIA Player Multi VST_x64 and use that instead of the VST3 version, then everything should play back correctly.

Hi Fred. I see, yes, that seems to be the case.

I am using a Mac, running OS Catalina (so my old software doesn’t work and I can’t attach my Firewire audio interface… :frowning:( )

I have located two Arias in Library/Audio/Plug-Ins/VST called ARIA Player VST Multi and ARIA Player VST. The multiplayer doesn’t appear in the vst choices in the Play window which only shows ‘Aria Player’. Will that be the VST3 version I recently downloaded from Aria? It doesn’t look as if the Whitelist is being read as neither of the VST2 names appears as a VST choice. The only thing that suggests a possible ‘user error’ is that both of the VST(2) players are of exactly the same byte length…

On the Aria player window in PLAY where you can load the sounds, Aria is ‘the latest version’ (on trying to update the engine from that point). Sounds like it’s the VST3 version and the whitelist is being ignored?

Be sure to use the Preferences link to get to the (appropriate) whitelist.
Be sure to spell the name of the VST perfectly in the whitelist.
Restart Dorico after you are done (just to be sure).

I’m not sure with ARIA, but with some plug-ins the dll/bundle names are different on Win and Mac. Derrek showed here the name for Win, please check if on Mac the ARIA bundle name is identical or change accordingly.

Hi Derrek/Ulf.

The names are different, yes. It now works. But things have been a bit odd, as in unpredictable…

On Mac there seem to be two players in Library/Audio/Plug-Ins/VST (note, not VST2): ARIA Player VST Multi.vst and ARIA Player VST.vst. I remove the .vst extension and use the edit whitelist link in Preferences.

For several attempts, the whitelist was evidently ignored as the player that was loaded seemed to be the most up-to-date version (reported by Aria when I try and ‘upgrade engine’ from the JABB/Aria pop-up). So that implies it’s the VST3 version.

So I did a couple of things - making system changes and quitting/loading Dorico as required.

  1. removed the Aria player from the VST3 folder to see if it forced Dorico to look in the VST folder - that evidently didn’t happen and no Aria player was loaded at all

  2. changed the name of the VST folder to VST2…again, no player was loaded

  3. deleted the VST3 Aria player into the Trash, renamed VST2 back to VST - nothing happened.

  4. used ‘put back’ command from the Trash to put the Aria VST3 player back in the VST3 folder.

This time, on start-up all the players were evident as choices in the Play stream/flow/window (sorry haven’t got used to your terms yet) and seem to work. The mixer is showing their existence though the levels don’t seem to change - something for another day I guess.

Thanks for pointing to the non-multi ability of the current VST3 Aria player. However, I would have thought that doing the Whitelist correctly, through Preferences should work first time, not after pfaffing about with file and directory names. Is there a rationale?

You have to tell Dorico where to look for it. At least in Windows this is under Preferences/Play/VST2 Plug-in Paths. The folder name doesn’t really matter as long as you’ve told Dorico to look in the correct folder for the VST2 you want to load.

@Jeffrey: So you have ARIA now loading into Dorico or not?
If you continue to have problems (also getting sound through), you could do ‘Help > Create Diagnostics Report’ which silently creates a zip file on your desktop. Please attach here.

You have to tell Dorico where to look for it.

Hi Fred. I’m not sure how I could do that, other than follow the earlier Youtube tutorial for Dorico 2 and do it all manually. On my system, the Whitelist (VST2whitelist.txt) that is available from Preferences/Play turns out to be in folder VSTAudioEngine3. This is confusing if one is coming at this for the first time. But…it does seem to work now, though channels evidently need to be correctly disposed.

So you have ARIA now loading into Dorico or not?

Hi Ulf. Yes. Two from the Library/Audio/Plug-Ins/VST folder - which includes the legacy multi which I evidently need and the version from the /VST3 folder. As I say, it now works though I need to think about how to relate the order of voices laid out in the System view to the allocation made by my user-template in my Aria player.

I think I have quite a lot of legacy versions of everything I use littered around the system. However you may observe something critical so please see attached the Diagnostics Report.
Dorico (372 KB)

Hi Jeffrey, thanks for the data. I had a scan through but could not find anything unusual at first sight. Let me know if you have a particular problem and I take a more closer look.

Hi Ulf. If you can’t see anything untoward, then that’s fine. It seems to be working OK at the moment. If necessary I’ll get back after a look at the forum. Jeff.

Hi Matshall -

I guess you’ve discovered that the effects from the Aria player returns to Channel 1 in the Dorico mixer. So it’s a good idea leaving channel 1 (output 1/2) in the Aria player empty, otherwise that instrument plays back on the effect return channel in Dorico. (i.e. place the first instrument on channel 2, output 3/4).

Does this mean (sorry…) that there can be only 15 slots for instruments in the player? i.e. 15/16ths of my band?

While I’m here, I have been trying to create a Percussion map for my JABB3 Jazz kit. Does anyone have one already? :slight_smile: I note that the Percussion Map seems to be part of the ‘editing’ that is not possible in Elements. If I create it in a smaller (<=12 peice) sized band, I wonder if I’ll be able to use it in a bigger (>12 piece) band.



No you can use all 16 channels with separate outputs each in Aria. When using separate outputs, most will simply disable the effects in Aria altogether (since they only work on outputs 1&2 anyway). It’s always been this way - it’s somewhat inefficient to provide reverb on all the channels of mult-channel output sampler.

Besides, you have plenty of reverb options available to you in Dorico.

Thanks SuperG. I’ve now discovered that using Outputs 1/2 to 31/32 enables me to see individual track outputs and I’ve turned off the Aria effects in favour of those offered by Dorico. I’m getting there step by step.