Generic Low Latency ASIO Driver not recognizing built in soundcard

Not sure whether this is the right forum, but here we go:
After an update from Windows, the Generic Low Latency ASIO Driver suddenly stopped recognizing my built in soundcard. This means that I had to download the ASIO4ALL drivers to get sound out of Dorico at all. Even if this is a decent workaround, ASIO4ALL unfortunately takes full controll over all the other sounds coming out of Windows and I can no longer make transcriptions from YouTube, Spotify etc. without shutting down the audio in Dorico first.

I have tried updating the drivers of my soundcard but the problem still persists. What do you recommend me to do next?

All the best!

I implore you to read the pinned FAQs thread for new users. It describes this exact problem and points you to this page: https://helpcenter.steinberg.de/hc/en-us/articles/115001124024-Windows-Dorico-No-sound-in-other-applications

Thanks for your reply! Unfortunately, that is not really the problem. I am already fully aware that you have to untick that box in order to enable other applications to play sounds. My problem is that the Generic Low Latency ASIO Driver is not allowing me to choose my laptop’s sound card for audio output at all. In the picture attached, in the “Output Ports” section under “Device Name”, in addition to the ‘L24q-10 (NVIDIA High Definition Audio)’ option (which is of no use unless there is a monitor with audio output connected to my laptop), there have once been, and should be, another option, which is my laptop’s built in soundcard. But now that option is gone. That is why I have to use ASIO4ALL instead of Generic Low Latency ASIO Driver to get sound out of Dorico, but that does not allow me to audition other applications at the same time, which is what I want to, hence this thread.

“After an update from Windows” is crucial - this is likely a driver bug rather than a Dorico bug. Have a look through what Windows has recently updated, driver wise, and see if you can roll back whatever it is. I had a total nightmare with my HP machine a few months back, exhibiting a similar problem, and it turned out to actually be down to a new graphics card driver…

The problem is that it appears that I can not roll back. The option is grayed out in the device manager. It is extremely curious that it was the graphic card driver that caused your problem. :astonished: Maybe I should try to do something similar on my machine…

Just in case it’s something similar:
My HP has two graphics cards: an NVIDIA Quadro M1000M and an integrated Intel 530 thing. Something updated, causing the computer to stop using the NVIDIA card at all, for anything. That sent HALion into a tailspin and caused no end of problems with the Steinberg Generic Low Latency ASIO driver. The eventual solution was actually to prevent the computer from using the Intel 530 graphics card. This probably shortens the machine’s battery life (between charges) and increases power consumption on mains, but it fixes the problem.

@Frigolitio: The problem you see might happen when Dorico is set to a different sample rate than the sample rate as set by the operating system.
In your taskbar, right click on the little speaker icon and choose “Open Sound settings”, then click “Device Properties” for the built-in soundcard, a new window opens.
In that window choose the “Advanced” tab and compare the shown Default Format to the settings in Dorico.

@Ulf: Aha, look at that, that solved my problem! Thank you very much! :smiley:

Good to hear :smiley: