Generic Remote failing to load

This in my case was a project put together on Cubase 8 (32 bit) on a PC running Win 7 - I had a song with a number of plugins including local and 3rd party plugins Halion SE, TX16 Software sampler, Bionic Delay etc and figured I could use my old Phatboy controller to use Cubase in a live configuration. I had submixed a number of songs into 6 tracks ie ‘Drums’ , ‘Bass’, Percussion etc etc 6 tracks on the mixing desk that I wanted to use each of the Phatboys 6 faders to control ‘Volume’, 'FX Send 1, 2, 3 and some of the FX plugin parameters etc, using the different Midi chanels to select different configurations

Open ‘Devices’ -‘Device Setup’
Click ’ + ’ on top left corner, add ‘Generic Remote’
Select ‘Generic Remote’ under ‘Remote Devices’ in left column on same window
Fill out top main panel with your ‘source’ fader values that link from the hardware (my case a Phatboy rotary knobs)
Fill out the below panel with the required destination controls
Check everything is working (fine in my case - 96 controls nicely set up and working- until I turned it on the next day)

then either,

Switch off Cubase Pro 8 , restart PC reboot Cubase
‘Export’ your named ‘XML’

Once refired up either with the same song reloaded or on a ‘blank’ song the Generic remote appears to have lost most of its ‘destination’ parameters in the lower panel, although the top panel still remembers it’s ‘source’ parameters . ‘Importing’ the previously saved XML file doesn’t reload the correct settings either. I tried this a number of times with blank songs, simple songs and songs with just local plugins with the same result - sometimes it remembered random settings but in short, unreliable!
I had a look at the saved XML file in an editor and it appears to read ok although I am no expert -I can clearly see both the ‘source’ and ‘destination’ panel settings , I also spent some time looking for the Cubase Preference file that supposedly contained the saved settings but alas could not locate it.

I would really appreciate getting this issue solved because If I can’t find a cure I will have to use Ableton instead for live shows - I would much prefer to use Cubase! :frowning: