Generic remote settings not remembered

I hear you. I think we all wish this part of the system was more automatic. I think if one has a defined hardware controller listed in the remotes, life is likely easier. Building a GR and getting used to editing the GR editor is time consuming and can be very frustrating when you are starting with it. One can get used to it and work with it, but it’s not a fun part of the program.

I think there may be some issues with the GR as well, but, you have to be a good user of GR before you can even identify that something is not working correctly or has gone wrong. I can’t yet offer any definitive bug reports. I’ve noticed some odd behavior.

Be very methodical and make sure you are totally clear about which GR is actually loaded. Get one thing working and then build it from there. Export your best working version. Then Import it, Apply, Reset – make sure the right GR is loaded. I name my GR’s incrementally and make sure I’m using the most current, best working version.

At times on my system the GR seems to need to a “wake up call” – at first it doesn’t respond to a control, but if I move one two or three times, it will work. I’ve not been able to get it to work perfectly, but, I have gotten it to do a lot of things. The time spent setting it up has been, all in all, very much worth the effort, imho.

So, yes, I hear you. The the GR editor is uncomfortable to work in terms of readability and and old fashioned (mail box data entry). I think there may also be some errors in how it is currently working in Cubase, but I can’t step-by-step demonstrate them yet because I don’t think I know GR well enough. For example, I’ve renamed a Bank and the text in the box goes garbled and the values are lost. Again, there a few other things I’d call “odd behavior” that have happened when editing the GR.

The documentation for GR is poor and there are not a lot of current videos about it. It’s been the same for a long time, so even older videos will explain some things. I recently posted a question about a function in GR and as yet no one seems to know the answer.

Thanks for the thread Jazzius and for chiming in Steve.

To me it’s the randomness. Instead of problem solving, we’re apparently doing a therapy group here.

After my most recent adventure I’m once again in a situation where most of the buttons knobs and faders are doing what I want. Oh, I just need to remember to go into the panel just enough to activate the Apply button to be able to click it to “wake up” the setup. No biggie in this world.

At the same time I’m mentally prepared to have some random configuration change send the GR setup back to the random stone age at the start of a series of random unsuccessful or partial imports, exports, learns - and wasted time. Part of the hobbyist experience called Cubase GR.

Archaic os with abandoned audio and controller drivers… Stuck in an ominous loop.

Makes me wonder if I should just bite the bullet and go for a Mackie Control device…? Something else? Something to have QCs, Transport and mixer functions controlled with a physical device. Overkill for a hobbyist?

If you like to tinker, before spending money you could have a look at this MCU MIDI implementation chart.

Maybe you can configure your device to mimic it, at least as insofar as what it sends, then you can use the Mackie Control Remote in Cubase.

https://www.mslinn.com/sites/mike/studio/midi/MackieControlMIDIMap.html

This is the painful road we’ve all been down and are still on. Thing is, you really only have to do this learning curve once and then you’ll be OK with getting what you can from this part of the program. Is it worth the effort? I think it is. Do we all wish it was better? I think everyone knows the GR functions could all be better, but, as you’re seeing, it does do some useful things (once you overcome the horrors of learning it). Good luck.

P.S. see the thread in my signature for posts from the some the real GR Gurus.

It’s totally unusable and utterly broken.

I issue a challenge: for somebody to make a film explaining, step-by-step, how you make changes in the GR editor, whereby next time you open a project or re-import that set-up, all settings coming back 100% as you set them.

And then for everyone to agree on this thread that, yes indeed, that works 100% of the time and is totally reliable. Then i’ll agree that it’s not broken.

Here’s a free way to make a screen capture: https://screencast-o-matic.com/

Since so many have problems making the settings stay, I agree there must be bugs/unfinished programming on steinbergs part. It works however on my setup as intended, but it was after lots of testing and trying, back and forth before I got it right. The video I posted earlier in the thread is how I do it, and that works for me. Follow it TO THE LETTER.

The strange part were I did wrong was not to export my setup then IMPORT exactly the same file on top of itself AND THEN APPLY AND SAVE it. (totally unlogic) No other place in Cubase or in other software is anything done like that. But it works, the GR stays as I want it, I have some houndred buttons/vpots assigned on my D8B mixer in my setup, and it loads everytime.

Hopefully this will be of help to someone. I have been having the same problems and it has been driving me mad. It turns out that I wasn’t renaming the control name column properly. Instead of calling my controls Freq 1 or threshold etc they were called knob 1, knob 2. These names were often duplicated and this was what was causing the problem. Once every control had an individual name the problem of Cubase forgetting assignments went away. I am still doing the export and import thing but it does seem to be working.

Regards

Andy

I have the same issue. CubaSE 9.5. I also have C10 but have not tried that.
Mac OS 10. Pain in the ass.

Yes, the trick is to give each entry a different name, i.e. fader1, fader2. then apply, then export, then import, then apply. and then it works.

It still doesn’t work in my case, all names are different.

When I quit and restart Nuendo, it does remember the settings; when I restart the Mac, it won’t.
That said, it does load the xml but have to connect it manually.

I use it with Touch OSC btw.

Anyone else?

In addition to my previous message: I think in my case Touch OSC Bridge is the problem -> OSC Bridge is a little piece of software that creates a virtual midi port: the connection between my controller (iPad) and the Mac. Works fine with Windows but fails to load the midiport automatically on a Mac.
Anyone else with this setup?

Its not fair to blame the software.
It is not broken here at all. You indeed have to use unique names for every entry otherwise the file gets rejected at next startup.
It’s a known common mistake, I’ve been there myself.
If you have made a working remote: export it to where you want it to live. Quit cubase. Then restart cubase. That should be all.
If it’s not working like this for you, your remote file has issues like double entrys , or identical names.
Good luck